This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 19, 2019 at 9:03 am #3841065

andreiG-7

Hi,

I want the default language to have a directory.

But I don't want to set-up a root page. How can I make the site redirect to the default language in it's default directoy?

Thanks

May 20, 2019 at 3:51 am #3843561

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

It's not possible to have a "default language with a directory" without root URL or page. You can achieve this with custom programming work which is beyond the scope of our support.

At this point, I would suggest you consider contacting one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors/

Before doing so please have a look also here:
http://wpml.org/documentation/support/wpml-contractors/guidelines-for-people-looking-for-consulting-help/

You will get the custom assistance you need to get on with your project.

Also, If you wish to use the root page, I would like to direct you to a relevant article from our documentation which should contain all the information you need to know to create "default language with a directory"

https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

If there is anything missing, or you'd like clarifications, I am here to help. Just drop a reply here so I can help you further.

Thanks

May 20, 2019 at 7:10 am #3844089

andreiG-7

Hi,

Thank you for your response.

The issue is that I set the main language in it's directory, I did not create the root page. And it automatically redirects to the default language. It works as I wanted it to work, but I don't know why.

Browser language redirect is turned off.

Thanks,

Andrei

May 20, 2019 at 7:43 am #3844363

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, I just checked the same settings and it looks like without selecting the root page the directory is working.

Since it's working, you can continue to keep that setting.

Let me know if that works.

Thanks

May 20, 2019 at 7:47 am #3844415

andreiG-7

Well, thank you!

But it seems a bit strange to have discovered a feature by mistake 🙂 All the documentation I've read, including your initial post referred to the fact that it can't work like this.

So I am concerned about future stability, if using this in this way is stable and works without glitches and bugs.

Thanks

May 20, 2019 at 7:56 am #3844519

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I discussed this issue with my colleagues and they mentioned that it's normal behavior and it's expected to work, but they also mentioned that on many cases they were receiving 404 errors or timing out errors due to this when you type the root domain manually.

Being so, I recommended you to either use the root page or use custom programming code to achieve the functionality.

Let me know if this helps.

Thanks