This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by stefanusP 2 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 15, 2019 at 9:08 am

stefanusP

I am trying to: Use Elementor's standard theme "Hello" with WPML-option "Different languages in directories" - "Use directory for default language" - have a page as 'root page'

Link to a page where the issue can be seen: hidden link

I expected to see: The created 'root page'

Instead, I got: a blank page

Issue: when switching to Theme "Twenty Nineteen" it does show the created 'root page'. I suspect that "Hello" doesn't work well because the 'root page' is not created as a normal page, e.g. it is not shown in the page-overview (see screenshots attached).

July 15, 2019 at 11:02 am #4210107

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue,

This seems like there is an error and the page fails with a white page,

Please resave the permalinks check if the .htaccess file has not corrupt data.

It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:


define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Kind regards
Raja

July 15, 2019 at 11:21 am #4210341

stefanusP

Hi Raja, thanks for your response!

As follow up I did the following:
1) navigated to the permalink-settings and (without changing) I saved them.
2) In the c-panel I navigated to the .htaccess file and opened it with the editor, without problem. Is this the check I should do, or what else?

The WP_DEBUG was true since earlier this morning and was too big for pastbin (I am not a pro-member). I copied the last lines in: https://pastebin.com/hn7HQRKG

The problem is still there. Hope you can give further support!
Wr, Stefan

July 15, 2019 at 11:32 am #4210501

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan

The Pastebin you have share is a private link which is only accessible to you. Please change the link as public so that I can view the details.

Please copy the .htaccess to a new Pastebin let me check if there is an issue.

Please note the URL you share here is not visible to other users, it's safe to share the details here.

Kind regards
Raja

July 15, 2019 at 11:39 am #4210555

stefanusP

Hi Raja,

the setting is now public and here you can find the .htaccess: https://pastebin.com/jmR0M8QL

Wr, Stefan

July 16, 2019 at 4:39 am #4216127

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Please provide a snapshot (copy) of your site for detailed debugging, You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/.

I have enabled private fields for you to securely share the details.

Kind regards
Raja

July 16, 2019 at 6:23 am #4216523

stefanusP

Hi Raja, hereby:

DATABASE:
hidden link

PACKAGE:
hidden link

INSTALLER:
hidden link

LOG:
hidden link

July 16, 2019 at 1:51 pm #4220709

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

I am able to reproduce the issue, but there is nothing in the error logs to about the issue. In order to isolate the issue, I request you to please upload Elementor plugin to the sandbox site.

One Click Login:hidden link

Please complete WPML setup add a few languages, Check if you can reproduce the issue with bare minimum setup. Let me know once done.

Kind regards
Raja

July 16, 2019 at 2:11 pm #4220895

stefanusP

Hi Raja,

Thanks! I have updated the sandbox site, as the original site:
- installed Elementor PRO
- set some languages in WPML
- WPML-option "Different languages in directories" - "Use directory for default language" - have a page as 'root page'
- Created the root page (via the WMPL menu) - and this is shown on the root page!
- Now uploaded Elementor standard theme "Hello" - the root page is blank, so the same issue as on my own page

Hope this helps you and that you can analyze and resolve this. Thanks!
Wr, Stefan

July 17, 2019 at 5:50 am #4225975

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for your efforts,
This seems like an issue, I am able to reproduce the same. I have requested second-tier supporter to have a detailed look into the issue, I will let you know once I have an updated.

Kind regards
Raja

July 17, 2019 at 1:08 pm #4230315

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

For your information, The issue has been escalated to the concerned team for further testing,

Kind regards
Raja

July 17, 2019 at 1:28 pm #4230541

stefanusP

Thanks Raja, I hope they can fix this shortly.

July 18, 2019 at 4:55 am #4234959

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

This is something that is being worked on, For the internal purpose, I am marking this thread as escalated. I will keep you posted with any updates.

Kind regards
Raja

July 22, 2019 at 1:03 pm #4257591

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for your patience,

The issue seems to be related to the Hello Elementor theme which is missing single.php and page.php files in the theme folder. Please create both the files in the theme root and paste the below code in the files (single.php and page.php) this will solve your issue.

<?php
if ( ! defined( 'ABSPATH' ) ) {
    exit; // Exit if accessed directly
}
get_header();
while ( have_posts() ) : the_post();
    the_content();                
endwhile;
get_footer();

Please let me know if that helps.

Kind regards
Raja

July 23, 2019 at 10:19 am #4265059

stefanusP

Hi Raja,

thanks a lot, it is resolved with the provided solution!
Have a nice day.

Wr, Stefan
Entrepreneurs.link