This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Root page: Selected WordPress page NOT displaying

Solution:notice the parameter in the end of your URL ?v=7516fd43adaa

this is what is causing the redirection and it is coming from WooCommerce GeoLocate feature

please deactivate it and let me know your results

https://gplchimp.com/how-to-enable-geolocation-in-woocommerce/

Relevant Documentation:

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by lilyM 6 months ago.

Assigned support staff: Bobby.

Author Posts
April 16, 2019 at 10:28 am #3620961

lilyM

Following directions found on the WPML "Language Directory for the Default Language" page, I created a Root page that allows site visitors to select their preferred language. I enabled and saved the "Use directory for default language" option and then clicked the "Create root page" link. Having done so, I added my content to that page and published/saved it. I then updated my permalinks and cleared my cache.

However, when visiting the site, I am NOT being shown the root page I created that offers language selection, but instead the English language homepage.

Can you help me resolve this? Thanks.

April 16, 2019 at 9:37 pm #3625769

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please verify that you have followed the steps here
=> https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/#selecting-a-wordpress-page

i have test this on my staging enviroment and it is working as expected

hidden link -> takes you to ROOT

hidden link => En page default language

hidden link => Es page translation

when i visit your site it seems that i am redirected to EN even if i try to visit the website without the directory in the URL, this might be causing the issue here.

April 17, 2019 at 8:32 am #3628511

lilyM

Thanks for your reply. I've confirmed that I have properly followed the steps for "Selecting a WordPress page". However, when visiting the site, I am NOT being shown the root page I created that offers language selection, but instead the English language homepage.

How can this be resolved? Thanks.

April 17, 2019 at 9:01 am #3628861

lilyM

Is it possible to transform this into a support chat? because of the time difference, this could well take days to resolve.

Also, I suspect that the support team will need to access my WordPress. However, I don't see how I can provide that access. Is it still possible? Thanks.

April 17, 2019 at 7:43 pm #3634557

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Unfortunately i cannot switch this ticket back to a chat support ticket but i can find another supporter closer to your time zone. (what is your time zone) [or you could start a chat support ticket separately ]

Additionally i believe in my previous thread post i mentioned that for anybody to view your root page they need to visit your site here hidden link

which is impossible as there is constantly a redirect to either language as shown bellow
hidden link

To Resolve this issue you will need to resolve this redirect

1. Go to WPML->languages->Browser language redirect and deactivate
=-> Let me know your results

2. If the above does not resolve the redirect then please review the following report as something is causing a redirect and that is the cause of the problem since you cant access hidden link directly where the root page resides

Here is the actual redirect report

hidden link

HTTP/1.1 307 Temporary Redirect
Date: Wed, 17 Apr 2019 19:35:30 GMT
Server: Apache
X-Powered-By: PHP/7.0.33
Pragma: no-cache
Vary: Accept-Encoding,Cookie
Expires: Wed, 11 Jan 1984 05:00:00 GMT
Cache-Control: no-cache, must-revalidate, max-age=0
X-Redirect-By: WordPress
Set-Cookie: PHPSESSID=c9b51e4fe5127ec6d9ae5a8f36401409; path=/
Upgrade: h2,h2c
Connection: Upgrade
Location: hidden link
Transfer-Encoding: chunked
Content-Type: text/html; charset=UTF-8

hidden link

April 18, 2019 at 8:46 am #3637431

lilyM

I went to WPML->languages->Browser language redirect but it was already disabled (see screenshot). in my cpanel for this domain there are no redirects configured. I have the "Redirection" plugin installed so I disabled it, cleared the cache and still the site redirects to the English language homepage.

What may be causing this redirect??

By the way I am in Italy: Time Zone is Central European Summer Time (GMT+2). Thanks again.

April 18, 2019 at 6:56 pm #3641539

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the additional information

notice the parameter in the end of your URL
?v=7516fd43adaa

this is what is causing the redirection and it is coming from WooCommerce GeoLocate feature

please deactivate it and let me know your results

hidden link

April 19, 2019 at 9:44 am #3644593

lilyM

OK, deactivating that was successful. Thank you for your help. I will mark this as resolved.

April 19, 2019 at 9:44 am #3644595

lilyM

My issue is resolved now. Thank you!