Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The client would like to use URL structure different domains in directories with the default language in directory with root page. Then, when the user types mysite.com, they see the root page with a custom template & language switcher, and after selecting a language they redirect to that language home page.

Solution: If browser redirect is enabled, disable this. Otherwise, the customers will get redirected to their browser language homepage.

Also, there was a function in this child theme that was automatically redirecting to the language homepage and skipping the root. Switching to the default theme allowed us to find this and then remove the redirect from the child theme functions.php

This topic contains 5 replies, has 2 voices.

Last updated by Lauren 3 years, 7 months ago.

Assigned support staff: Lauren.

Author Posts
May 1, 2016 at 5:14 am #872630

Janatan Snippert

I am trying to have default language in directory with root page:
when user type mysite.com they see root page with custom template & language switcher, and after selecting a language they redirect to that language home page.

Instead, I got:
root url (mysite.com) redirects to default language directory(mysite.com/fa/) and i never see the root page!

Steps to duplicate the issue:

i searched and read many forum threads related to issue but no success to fix that.
cannot see root page in any way!

a'm also using this theme: hidden link

May 2, 2016 at 5:33 pm #873476

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hi janatan, do you have browser redirect enabled in your WPML -> Languages settings? If so, please try disabling that and see if you can get to the root page.

You can also try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

If neither of those resolve the issue, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

A. Update all WPML plugins & WordPress core.

B. Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen.

C. With the default theme still active, enable all plugins and disable all WPML related.

D. If the issue is gone after either step B or C above, activate each plugin one by one to find out which plugin is causing the issue.

Does the issue still persist when you do each step above?

May 8, 2016 at 12:59 pm #877679

Janatan Snippert

Hi lauren, i checked all mentioned steps, and by changing theme to one of default themes (step c), issue resolved, but obviously i don't want to use default theme.
i looked into functions.php of the theme an it's child theme and everything seems normal!
is there a special place in my theme to look for the problem?

May 9, 2016 at 6:32 pm #878576

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hi janatanS, if it is a child theme, you will need to look at the parent theme to try and find where the redirect could be happening. I would activate the parent theme and see if the issue happens. That way you will know which theme you need to investigate.

As far as I can see, the Dastak theme is not listed in our compatibility list: https://wpml.org/documentation/theme-compatibility/

We can suggest the theme's author to join our Go Global Program (https://wpml.org/documentation/theme-compatibility/go-global-program/). You can either contact them directly or provide us their contact details (name + email) so we can get in touch with him.

May 10, 2016 at 8:53 am #878940

Janatan Snippert

thanks lauren,
there was an unnecessary redirect hook in functions.php, and when i removed it everything works perfectly.

May 10, 2016 at 6:12 pm #879574

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I'm glad you were able to find the hook that was the culprit 🙂