This thread is resolved. Here is a description of the problem and solution.


Royal theme not copying theme settings for translated pages


It was this setting that made it work:

Relevant Documentation:!/1_how_to_translate

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by emelieC 10 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
July 18, 2019 at 9:29 am



This is a continuation of

We never finished the topic. I am providing details so you can have a look at the problem.

Kind regards,


July 18, 2019 at 12:48 pm #4238741


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Marcus.

I've read the other ticket that you have with this issue.

The Royal theme by 8Themes is officially compatible with WPML.
Could you please confirm that you are following the instructions from the theme developers on how to work with the Royal theme and WPML?
You can find those instructions here.
hidden link

Thanks for the access details. I can access your site. But I don't understand where I can see the problem. When I go to the English translation of the homepage, I do not see this problem. The layout has no sidebar as the original homepage.
Can you explain to me where I can see this problem?

In addition and also very important, please update WPML and its add-on to their latest versions because I can see that they are not updated on your site.


July 21, 2019 at 9:13 pm #4253005


It was this setting that made it work:
hidden link