Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Diego Pereira 1 month, 3 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
December 20, 2018 at 2:06 pm

maxK-7

I am using the CyberSyn Plugin to import English and German RSS Feeds into my WordPress Post.

I want my English RSS feeds to be imported to my English WordPress posts and my German RSS feeds I want to be imported into my german WordPress posts.

Currently, both the English and German RSS feeds are imported automatically to my german WordPress posts.

My current workaround is to switch to English in the WordPress backend manually and import the English RSS feeds. Like this, the English RSS feed is imported to the English WordPress posts. I do the same for the German RSS feed / WordPress posts.

The plugin is only useful if the process works automatically for both English and German.

I attached the default settings of the plugin.

I am of course happy to provide more information if needed.

Any input is appreciated!

Bildschirmfoto 2018-12-20 um 14.54.32.png
Bildschirmfoto 2018-12-20 um 14.53.58.png
December 21, 2018 at 11:54 am #3024606

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @maxk-7, welcome to the WPML support Forum!

This seems to be a compatibility issue. The plugin is not listed at our compatible plugins list: https://wpml.org/documentation/plugins-compatibility/

In these cases, these are the procedures:
- Install the plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
- After this, I will check the problem in this new installation and look for a quick solution
- If I can not find a solution, I will forward the problem to our compatibility team
- The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the plugin to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the plugin and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

All the best,
Diego

December 21, 2018 at 10:36 pm #3026325

maxK-7

Hello Diego,

Thank you very much for your support.

I have installed the cybersyn plugin at the above-mentioned sandbox environment and reproduced the problem.

I have set up an English and a German RSS Feed and it is automatically imported to the English WordPress posts.

Currently, the cybersyn plugin is set up to automatically pull 1 RSS Feed every 10 min. This will continue until all RSS Feed articles are imported to the WordPress posts.

In order to test this I would suggest to delete all posts and then in the WordPress backend menu go to cybersyn --> RSS / Atom Syndicator. When on the RSS / Atom Syndicator page select both RSS Feed Titles and press "Pull selected Feeds now". Like this, you will manually pull the feeds to the WordPress posts.

You will see that both the German and the English RSS Feeds will be imported to the English WordPress posts and they are not separated into English Post/ English Feed and German Post / German Feed.

If you need more information please do not hesitate to ask further questions.

Thank you very much for your support.

Best
Max

December 24, 2018 at 11:21 am #3030357

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. I deleted all the posts then clicked on "Pull selected fields now" (under Cybersyn > RSS/Atom indicator). But it only imported 2 posts (it has 60 posts before). Is this correct? Did I miss a step?

Could you please also describe us the steps of the manual import workaround? I will need to escalate this ticket to our compatibility team, so the more details, the better.

Kind regards,
Diego

s4.png
December 24, 2018 at 1:55 pm #3030612

maxK-7

Hi Diego,

currently, I selected in the settings that only one post is pulled at a time and it does that automatically every 10 min or manually every time you press "pull feed". You are pulling two posts because there are two RSS Feeds (a German and an English feed). So yes this is correct. If you want more posts then you just need to select both feeds and press pull again as many time as you like. Or you have to update the settings of the RSS feed. You can update the settings of each individual RSS Feed next to the Titel where is says edit (please see attached screenshot). Under the point "Maximum number of posts to be syndicated from each feed at once" you can choose the number of posts that shall be pulled each time.

Regarding the manual workaround.
Step1) select the WordPress language that you want the feed to pull the posts too (for the German RSS Feed select the German language and for the English RSS Feed the English language)

Step2) go to Cybersyn > RSS/Atom indicator and only select the RSS feed with the currently selected WordPress / backend language. You can see in the name of the RSS feed (DE or EN) if the RSS Feed is English or German. Then you do the same process for the other language. Like this, you should have one English and corresponding German WordPress post, if you have successfully importet both RSS, feeds as mentioned above.

I hope this all makes sense and I tried to be as precise as possible.

Best
Max

step 6 go to posts and you see the sorrespodning german post to the previosly pulled english post.png
step 5 select the german rss feed and press pull.png
step 4 change to german backend - you see no posts.png
step 3 you see one english post.png
Step 2 select english feed and press pull feed.png
step 1 select english in the backend.png
December 26, 2018 at 6:16 pm #3034756

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks!! I forwarded the details to our Themes and Plugins Compatibility Team and they will take a look at the issue and contact the author if needed. Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

It would be great if you can also contact the author asking him to reply us. You could also refer them to our Go Global program so that we can help them make their product compatible with WPML: https://wpml.org/documentation/theme-compatibility/go-global-program/

This may help expedite the process.

Kind regards,
Diego

December 27, 2018 at 10:32 am #3036440

maxK-7

Dear Diego,

I have contacted the author of the plugin and have asked him to assist your support team.

It would be great to be updated on the status as soon as new information comes forth.

Thank you very much for your help.

Best
Max

December 27, 2018 at 2:52 pm #3037314

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks! I'll let you know as soon as I get feedback from the compatibility team.

Kind regards,
Diego

January 21, 2019 at 6:10 pm #3113682

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

We tried to find a workaround but unfortunately it was not possible, because it is necessary to implement new features in the plugin to make it compatible. So we are contacting the plugin's author.

It would be great if you can also contact the author asking him to reply us. You could also refer them to our Go Global program so that we can help them make their product compatible with WPML.
https://wpml.org/documentation/theme-compatibility/go-global-program/

This may help expedite the process.

Kind regards,
Diego

January 23, 2019 at 6:47 pm #3122193

maxK-7

Hi Diego,

So I was contact bei CyberSEO basically the premium version of the plugin. He sent you guys an email and is waiting for a reply.

Best
Max

January 23, 2019 at 7:01 pm #3122224

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks for the update. I notified the compatibility team.

Kind regards,
Diego

January 24, 2019 at 5:43 pm #3126328

maxK-7

This is what the author of the plugin wrote your support:

I'm the author of CyberSyn (https://wordpress.org/plugins/cybersyn/) and CyberSEO (hidden link) content aggregation plugins. Recently one my customer asked me to integrate WPML support into my plugins (https://wpml.org/forums/topic/rss-feed-post-importer-is-unable-to-allocate-differentiate-between-en-de-posts/).

In a few words, the customer wants to be able to automatically assign a language (the one you can choose in the WPML's "Language of this post" drop box) to every syndicated (imported) post.

Do you have some developer API or maybe you could tell me which exactly function of your plugin should I use to do so from my own code? I mean when the post is created by CyberSyn/CyberSEO via wp_insert_post() and my plugin has its ID, how can I assign a WPML post language to it?

January 25, 2019 at 9:35 am #3128303

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks,! I notified the compatibility team.

Kind regards,
Diego

January 28, 2019 at 8:24 pm #3137464

maxK-7

I am sorry to stress this matter, but the author still has not received message from your compatibility team.
Max

January 29, 2019 at 3:11 pm #3140391

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

If the message was sent to our go-global program, our team will reply soon (there is a small queue for the go-global program).

Our team will help the author to fix the compatibility, test the plugin and then add it to our list: https://wpml.org/documentation/plugins-compatibility/

Kind regards,
Diego