This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: the client has one custom post type, "Projects" that has been set to untranslatable, but some portfolios appear in the other languages.

Solution: even if Project custom post type is set as untranslatable, you can still create Project in all your languages as independent pages. These portfolios are not connected to the original, and if you visit their page you don't see the language switcher. To fix the issue, go to the Project -> All project page and change the language with the top admin bar. Then search for the Project you want to delete and you can trash it or make it a draft.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by priiduT 4 months, 3 weeks ago.

Assigned support staff: Laura.

Author Posts
May 17, 2019 at 5:51 pm #3836389

priiduT

I am trying to:

Portfolio category and items are disabled to translate, but google has still indexed them as double content.

Link to a page where the issue can be seen

hidden link
hidden link

I expected to see:

Nothing should be in Russian site as portfolio items

Instead, I got:

I can't understand how this showing the link, since there is no way you can add new items to english and russian portfolio.

May 18, 2019 at 11:10 am #3838747

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

I don't get the situation here. You say that portfolios can't be translated, yet the page you linked exists in both English and Russian. Do you mean this page shouldn't exist? Do you see it in the backend? If so, can you delete it?

May 18, 2019 at 3:00 pm #3839127

priiduT

Exactly, page is not visible in the backend and is visible in the frontend.

I just tried all of the projects can be accesible via link change - u just need to put ru or eng in front of /tehtud-tood/ and there you go, it shows the url which is in estonian, but should not be visible and show 404 instead.

hidden link

and yes, in the backend, its not visible and you cannot modify it there.

May 18, 2019 at 3:14 pm #3839187

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

can you check if by any chance it's in trash?

Try clearing the cache in WPML going to:
WPML -> Support -> "troubleshooting" link -> "Clear the WPML cache" button
Please do a backup first.

If this didn't help, could you please provide credentials so I can better check the issue? I'll enable a private reply.

May 19, 2019 at 1:10 pm #3841811

priiduT

Are you there?

May 21, 2019 at 8:52 am #3853325

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

sorry for the late reply.
I checked your site and I can see the project in both English and Russian. Here is English for example: hidden link
They do not seem to be translations of the Estonian project, but they exist so of course they can be viewed and indexed. If you don't want to have them just delete them and you should be okay.

You might also want to add a 301 redirect so if someone by mistake opens those links they are redirected to the Estonian page.

May 21, 2019 at 9:20 am #3853501

priiduT

No, I can't see them in the list of projects with flags, can you turn it on somehow so i can change them as drafts at least?

I have disabled translations for projects, so how they are in multiple translations suddenly, this is very weird and above my knowledge of the system, can you explain...

May 21, 2019 at 9:22 am #3853509

priiduT

I would need to understand why system suddenly changed the way of working, is it that the update ruined something there and I have to restore the situation that was before, if yes, then I would need to understand how to turn on visibility in the view where all the projects are listed so I can see which project have translation to which language so I can draft them out so they cannot be accessed.

Would you help me to do that if possible?

May 21, 2019 at 9:45 am #3853785

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

as I said, these are NOT translations, so it's expected you don't see them with the usual interface with flags. Even if you disabled translation for projects, you can still create projects in Russian and English, as independent pages. And in fact, if you visit the Russian or English pages, you don't have the language switcher, as they are NOT connected to the Estonian project.

To search for them, I went to the Project -> All project page and changed the language with the top admin bar, then I searched for the page title and I found it both in English and Russian. If you edit them you can choose to delete them or make them drafts.

May 23, 2019 at 8:35 pm #3879353

priiduT

Thank you!