This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Mihai Apetrei 3 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 12, 2019 at 6:02 am #4195383

davidB-44

I am trying to: add Russian language at Languages -> Add/Remove language, tick the checkmark for Russian and hit apply

Link to a page where the issue can be seen:

I expected to see: Russian language is enabled

Instead, I got: it is not added to the language list

July 12, 2019 at 1:23 pm #4199305

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. Can you please try this:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

2. If that still doesn't work, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

Can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai Apetrei

July 17, 2019 at 12:41 pm #4230123

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they are working.

From what I can see, you are having a multisite setup.

1. Please create a full backup of the site?

2. Please run all the updates from here (hidden link).

3. From what I can see, you are also using older versions of our plugins.

Please try to manually update the plugins by following the steps below:

❌ Before proceeding please make a full website backup! ❌

  • download the latest version of WPML from https://wpml.org/account/downloads/;
  • disable WPML Multilingual CMS
  • delete WPML Multilingual CMS (the settings and the translations are saved in the database so they will not be deleted);
  • upload the freshly downloaded WPML plugin from Plugins → Add New → Upload Plugin
    → Activate WPML
    ;

Now please see if the issue is still happening.

It is very important to make sure that the backup is done first so that there are no risks.

Please let me know how that goes.

Kind regards,
Mihai Apetrei