This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Bruno 1 year ago.

Assigned support staff: Bruno.

Author Posts
October 8, 2018 at 7:17 am #2794883

stanislavR

Hi Guys

I have here this problem in russian cirillic. When I copy the url from browser it come out this way: hidden link

but in browser it show correctly: hidden link

The problem is that by linking posts in my website it come the long url with code. I found out also that google had no indexed the russian part of website and show it as a error in page.

Please help what to do. The site is in 5 languages but only the russian have problem.

Thanks

Stanislav

October 9, 2018 at 4:33 am #2798230

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

This does not seem to be related to WPML. In a new installation, without WPML installed, this is the same. This looks like it's browser-related.

This seems like the way the browser handles this. I tested both on Chrome and Firefox. Both display this in the same way when copying the URL and paste.

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

October 9, 2018 at 6:09 am #2798324

stanislavR

Hi

Is there some solution to change the strings from cirillic to latin? And how?

Thanks

October 10, 2018 at 6:33 am #2803105

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Unfortunately, I do not know any way to change the characters for Latin. I've looked at some plugins, but I'm not sure if they should work as you would like.

You can look in the WordPress repository and try to find some plugin that meets your needs: https://wordpress.org/plugins/

Another way should be to do this manually. I found this link on Google: hidden link. This may help.

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

October 11, 2018 at 6:52 pm #2809552

stanislavR

Hi Bruno

I found something what can do problem. Please can you explain what happen here?
Language URL format show all in red colour. Please see the attachment.

But in the site seem to be all ok hidden link

Thanks

October 12, 2018 at 2:31 am #2810317

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

No. This message shows that WPML was unable to validate the domain. You may notice, however, that this is a false positive as long as your site works properly.

What you reported initially, however, is the problem with links that are not being displayed correctly.

This same "problem" is replicated in a new installation, with WordPress configured in Russian. For this reason, I can not see any bug in WPML. This is because it is replicable, even without WPML installed.

About the problem you're reporting in your last post, it's probably a cache and the return is a false-positive, as the site works correctly.

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.