Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Yvette 7 months ago.

Assigned support staff: Yvette.

Author Posts
October 27, 2020 at 4:30 pm

antonD-13

We are manually entering prices for translated products/variations. We only enter a sale price in the default language, but this sale price is showing for all languages on the frontend.

October 27, 2020 at 6:18 pm
October 28, 2020 at 10:40 pm #7330057

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Hello

I will be helping you now.

I read thrrough the ticket and I am not sure I fully understand the issue. In general, WCML is will always show the same price (sale or regular) in all languages. Of course there is a problem if the backend is showing one price but the frontend is showing a different one.

Right now, I see that you have several currencies but they are set to be 1=1 conversion. That is good for our troubleshooting. This means, for me, that the price should be the same in all languages and all currencies.

So, I went to the test product you were working on with Lauren here:
hidden link

I am seeing the same price in all languages and currencies.
This is what I expect given that WCML will syncronise ALL pricing data and will not allow different prices to be applied to the same product.

So, could you please step me through an example that is not working. Please give me the followin details:
- the URL of the product
- the variation values to use
- the expected price in CZ and the expected price in Slovak

Thanks

October 30, 2020 at 6:46 am #7341275

antonD-13

Hi,

It should not be same price in every language because I have use your Multi-currency setup, and it should show different prices by different languages.

Everythink works fine, except one product: hidden link
Here it show for some variants same price as in default language. That is wrong, when you compare settings in product admin.

Weird is that for some variants it shows prices correct which are setted for CZ version of page in KČ, and some shows incorrect.

Also when I followed your colleague steps, this product disapeard from my product feed.

Is it understandable now?

URL to product is same as you sent me in your last reply:
You can check the variations in admin, issue is only with variants which have an atribute "Opierka hlavy" to "Nie"
Expected price for these variants in CZ is 12960Kč - regular price, sale price is not setted for CZ. Expected price of these variations in Slovak is 623 € - regular price and 498.4€ in sale price.

Thanks.

October 30, 2020 at 8:49 pm #7347367

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

OK.

The username/password is not working when I cut&paste them into the system login screen. Please check them.

October 31, 2020 at 8:07 pm
November 2, 2020 at 8:35 pm #7361943

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Hello

I´m not sure why that particular attribute "disappeared". What action was taken exactly?

Here´s what I did so far:
1. Cloned your product to a new simplified product with fewer variants
hidden link

2. I then entered some prices and checked the frontend.
It seems to me that this is working as expected. Can you verify?

If you concur. Then it seems that something corrupted the taxonomy association with your existing variations on that partiular product. Sometimes it is faster to recreatae the product than to try to figure out what happened and how to fix it.

I wait for your comments and if you agree that the cloned simplified product is working. Let´s try rebuilding some of your problematic variations there just to make sure the pricing is working as expected.

November 3, 2020 at 7:41 am #7364509

antonD-13

Hi, please do not publish new products on ths live page again.

I duplicated this product again, and set the correct settings for it. Now in CZ it works fine, but in some other countries still prices are not correct. It is for excample in Swiss, EN, DE.

In your product there were no variants with which were the issue.
If you need to create new products make it private or make it on cloned website.

Thanks.

November 3, 2020 at 7:43 am #7364565

antonD-13

And in this nre product I duplicated in the languages where is incorrect price - there show every variant wrong prices. In the default product we were tested was issue only with sale prices and only in some variants. Really weird.

November 3, 2020 at 6:37 pm #7370323

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

1. Staging site
Do you have one that we can use freely for troubleshooting?

2. "Nie" taxonomy term
I created my test product with ONLY this term value since it was what was causing issues.

So, now I am thinking maybe, since it is only used in this one product (right?), that you try recreating the taxonomy from scratch.
So, it implies a data issue. We already tried recreating the product but this did not help.

Can you do this? Do you agree with this approach?

When you recreate your product - first try with a FEW variations just to make sure everything is working correctly first. e.g 4 variations. Once you are sure it is translating well, then I would add the other variations.

3. Deleted products
I also recommend that you always PERMANENTLY DELETE your products from the trash. In WordPress, these are still around and can interfere with troubleshooting. It is good to keep the system "clean".

November 3, 2020 at 6:54 pm #7370389

antonD-13

Hi,

1, No, I don´t have any staging site, you can copy page to your local host for testing.

2, Now you can see when product is duplicated, prices are incorect also for another term "Áno", nut only in few languages. CZ is now ok,, but issue is in others.

3, I deleted it permanently.

November 3, 2020 at 7:38 pm #7370519

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

1. Ok I will install and use the Duplicator plugin. Hopefully I will not need to ask for your assistance to make this work.

2. Did you RECREATE the Taxonomy "Opierka hlavy" entirely?
And did you then recreate a product as I asked with this new term but limited variations to make sure it was translating corrrectly?

November 9, 2020 at 5:09 pm #7410303

antonD-13

Hi, was you able to duplicate a page for testing purposes? Do you have any update about issue?

Regards,
Anton.

November 11, 2020 at 3:26 am #7420949

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Rome (GMT+02:00)

Hello

I had some technical difficulty with my environment that required I totally rebuild my space. Sorry for this delay.

I was able to install the Duplicator of your site on a local server. I had to remove a lot of the wp-config.php entries that were related to WP Engine in order for it to work as well as some "Must use plugins".

Once I got it up, I did a final configuration change to ease the testing and this was to set the prices on the shop and product page to be EXCLUSIVE of tax. In this way I could directly compare the price that was in the product variations with what I was seeing on the frontend.

I went through about 1/2 of the variations looking specifically at the prices in CZ Krona. They were all correct. I also checked GBP and CHF.

The duplicated site seems to have no inconsistencies at all.
Do you have a particular variation that is currently not working in that product? I can then focus on that but I did go through a good number of the variants.

The only other thing I can think to do is to ask you to migrate your site to a Cloudways server. Here, we can then BOTH look at the same thing. If the migrated site also does not show the errors, then we can deduce that this is a problem related perhaps to your server.

Please find below the instructions to migrate your site.
=======================================

To troubleshoot this issue without affecting your site I created a test server for you in Cloudways (https://wpml.org/hosting-partner/cloudways/).
If it is OK with you, we can migrate your content there to further debugging without any risk on your end.
To do the migration please follow these simple steps:

1.Install this plugin in your site: Cloudways WordPress Migrator (https://wordpress.org/plugins/bv-cloudways-automated-migration/)

2. After you activate it you will be redirected to the migration form

3. Fill it with this information:
--Email:
Your email here, as you will be notified about the migration progress.

--Destination Site URL:
wordpress-219768-1586088.cloudwaysapps.com

--Server Public IP Address:
198.199.78.128

--Database Name:
fnpqrwgkbh

--Database User:
fnpqrwgkbh

--Database Password:
QFD9M7EW5p

--SFTP User:
yvette-7319125

--SFTP Password:
Yvette-7319125

4. Agree with the terms of service and click on "Migrate"

5. More information:
hidden link
You will get an email when the migration starts, and one when the migration ends.

6. Let me know when the migration is ready and I will check the issue in the test site immediately.

The copy of your site will be online, but search engines won't index it (the copy) so you don't have to worry about duplicate content.

The information you share with us will be confidential. Once the problem is resolved the details you shared with us will be deleted from our records.
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

The topic ‘[Closed] Sale price showing incorrectly on the frontend of the site’ is closed to new replies.