This thread is resolved. Here is a description of the problem and solution.

Problem: We are using the Salient Theme and our problem is that the link of the button module of the vpbakery implementation is not pointing to a translated site but to the original

Solution: I added the following code in WPML -> Settings -> Custom XML Configuration tab:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>nectar_cta</tag>
            <attributes>
                <attribute>text</attribute>
                <attribute>link_text</attribute>
                <attribute type="link">url</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>nectar_btn</tag>
            <attributes>
                <attribute type="link">url</attribute>
                <attribute>text</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

I would like to ask you to follow these steps:
- Go to WPML -> Settings -> Activate Classic Translation Editor
- Edit the test page in German -> Make a small change in the content -> Save the changes -> Update the translation.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by martinK-107 1 month, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 2, 2020 at 11:07 pm #5827095

martinK-107

We are using the Salient Theme and our problem is that the link of the button module of the vpbakery implementation is not pointing to a translated site but to the original.

Page is in german, translated to english. The page with the issue and al pages that are linked there are translated. On the services page, all other links work fine and point to the english version, just the links in the button ("More") are point to the original german pages.

Link to a page where the issue can be seen:
hidden link (cannot been seen because we fixed it, by typing in the correct URL by hand, but this is not how it should work, since whenever we make updates to the page and translation, the old URL´s are filled in.)

I expected to see:
hidden link

Instead, I got:
hidden link

April 3, 2020 at 7:58 am #5829591

martinK-107

I have setup some pages where you can see the problem:

hidden link

when you click on the button, it should lead you to

hidden link

but it goes back to the original one.

Hope this helps

April 3, 2020 at 3:27 pm #5833737

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
Thank you for contacting WPML support.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to back-up the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

April 9, 2020 at 11:03 am #5875307

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
Thank you very much for the information provided.

I added the following code in WPML -> Settings -> Custom XML Configuration tab:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>nectar_cta</tag>
            <attributes>
                <attribute>text</attribute>
                <attribute>link_text</attribute>
                <attribute type="link">url</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>nectar_btn</tag>
            <attributes>
                <attribute type="link">url</attribute>
                <attribute>text</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

I would like to ask you to follow these steps:
- Go to Plugins -> Add New -> Commercial tab -> Download and install Sticky Links plugin
- Edit the test page in German -> Make a small change in the content -> Save the changes -> Update the translation.

Could you tell me if the links are been shown translated this time?

Regards,
Carlos

April 9, 2020 at 2:05 pm #5876685

martinK-107

Hi,

i went through your steps, but it still is not quite right. The link shows up in the translation, but the resulting link is not quite right. It ends up like this: hidden link

Also, the translation only works if the "hidden link." is not included in the link adress.

April 10, 2020 at 7:33 am #5881625

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,
Thank you very much for your reply.

I removed the English version of the 'test 01 de' page and translated it again. Now I can see that the links are working as expected.

Could you double-check with a new test page if the issue disappeared?

Regards,
Carlos

April 10, 2020 at 5:03 pm #5885393

martinK-107

Hi,

i tried with fresh pages, but the issue is still there. Maybe i am doing something wrong.

I set up two pages (aaaa_01 and aaaa_02) which link to eachother. They have NOT been translated yet. Just so there is no cach issue or anything. I would like you to try translating them and see if the links change accordingly. If so, please tell me how you did it 😀

April 13, 2020 at 2:56 pm #5897223

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
Thank you for creating these new test pages.

I activated the Classic Translation Editor and the URLs are displayed correctly there. Could you confirm that you can translate the URLs on the CTE?

Regards,
Carlos

April 14, 2020 at 8:08 am #5901743

martinK-107

Yes,

in the CTE the Links are displayed to be translated. Sure is a "workaround" that will work.
Thank you.

Are you working on implementation where the links of buttons etc. are translated automatically?

Best regards,
Daniel

April 14, 2020 at 10:37 am #5903343

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Daniel,
I'm glad to hear that the workaround solves the issue.

In order to automatically translate the links there is a plugin called Sticky Links. Please check the official documentation on this link: https://wpml.org/documentation/getting-started-guide/sticky-links/

Best regards,
Carlos

April 14, 2020 at 12:18 pm #5904089

martinK-107

My issue is resolved now. Thank you!