We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to have the same slug for the translated category?

Solution: Instead of editing the category you need to use the quick edit link. From there you will be able to change the slug of the category.

Relevant Documentation: http://recordit.co/j5hI2Ft3cY

0% of people find this useful.

Tagged: 

This topic contains 15 replies, has 4 voices.

Last updated by bonnyC 2 years, 6 months ago.

Assigned support staff: Otto.

Author Posts
April 14, 2017 at 7:17 pm #1254629

manonv

Hi,
I am really sorry about asking this, as I have saw a lot of posts about the same issue. But it still hasn't answered my question.
I am trying to: get the same category slug on different languages. For example I would like the slug to appear like this in the different languages:
hidden link (NL version)
hidden link (EN version)

and not like this:
hidden link (NL version)
hidden link (EN version)

I know a lot of people asked this before and that it is not possible to have two categories have the same slug. BUT I saw some website which appear to have it fixed. For example on this website:
hidden link (NL version)
hidden link (EN version)

As you can see, this person has the same slug for the category 'travel' in the two different languages! So how is it possible that this person got it working like this, when it apparently isn't possible?

On this website, I saw the same:
hidden link (EN version)
hidden link (IT version)

So I think it really might be possible to do this. How can I achieve the same links like the persons above have?

If it really is not possible to use the same slug for the two categories, then how can I make sure that WPML doesn't translate the categories at all? I still want translated posts, but translation of the categories is not really necessary. I just want to use the same category for my normal ánd translated post.

URL of (my) website where problem appears: hidden link

I hope you understand my issue.
Hope to hear from you soon.

April 16, 2017 at 10:29 am #1254945

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hello, @manonv.

Thank you for contacting the WPML support forum.

Because of limitation from WordPress itself, WPML can not translate the category's name.
WPML can only translate the categories labels that are appearing in the WordPress admin menu.
Nevertheless, WPML can translate the category's terms.
In your case, 'europe' is the category's name and 'netherlands' (for example) is the category's term.
Please, correct me if I'm wrong.
When translating the categories' terms, you can leave it the same as the original. For example, 'netherlands' can stay 'netherlands' in its translation.
1. Have you translated 'europe' terms ('netherlands' for example) on your website?
If not, when you'll do that so here hidden link you will also see the translated posts that are assigned to the terms that belong to the 'europe' category.
2. Have you translated your posts already?

This example hidden link that you bring above shows in fact what I'm saying here.
3. Do you agree with this?
And concerning this example hidden link, it doesn't look to me like a category but a simple page.
4. Do you agree with this as well?

If you will need more assistance from me, could you please share your Debug information with me?
You can read a detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Please could you provide me the additional info?

Thanks,
Itamar.

April 16, 2017 at 12:32 pm #1254960

manonv

Hi,

I don't really understand what you mean with category terms. I tried translating the term 'Netherlands', but it still translates the slug as 'netherlands-en'
I noticed that when I go to that english page you send me, I can see the posts assigned to that category, but I can't assign a post to that category yet, because I haven't translated it. But when I do translate it the slug appears as 'europe-en' and I don't want it like that.
I tried translating all of my categories, but the slug still appears with '-en' in the end, because I already have a categorie with that slug. I just want them to be the same as my non-translated categories.

I was busy with translating one post, and linked that to my translated 'Australia' (with '-en' in the end) category.

I put my debug information in here as well.

Thank you!

Kind regards,
Manon van Os

April 16, 2017 at 12:52 pm #1254964

manonv

Added pictures from the hierarchy of my non-translated categories.
I want it the same like that in English.
Note: I remove the 'category' slug in my settings. (Don't know if that's relevant)

April 16, 2017 at 1:27 pm #1254972

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Thanks, Manon for attaching the debug information.

Regarding this screenshot Schermafbeelding_2017_04_16_om_20.31.03.png, can you, please try to edit 'netherlands-en' and change it only to 'netherlands' and save and tell me if then it shows like you want it to show?

Thanks,
Itamar.

April 16, 2017 at 1:32 pm #1254973

manonv

Hi,
I tried changing it, but now it adds another -2 behind the slug.
See screenshot.

April 16, 2017 at 1:58 pm #1254983

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

I see, thank you.

From this screenshot Schermafbeelding_2017_04_16_om_20.50.28.png, I can see that you have a custom post type that is called 'Berichten' and the 'Destination' parent category that has child categories like 'Europ' and 'Netherlands' (child of Europe).
Can you, please tell me how you have created the 'Berichten' custom post type?
Does it come with your theme or is it created with a plugin?

April 16, 2017 at 2:10 pm #1254984

manonv

The 'berichten' post type was already in WordPress. It's just the Posts section but in Dutch. So it's not a custom post type I guess? The 'Portfolio' and 'Testimonials' are a custom post type though created by my theme, but I don't use them.
Yes it is true that 'Destination' is a parent category and has different child categories in it.
It's the same with 'Travel Tips'. I have different child categories in that category as well.

April 16, 2017 at 2:28 pm #1254986

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Ok. I understand, thank you for the clarification.
I've tried to replicate this problem on my local server.
I've switched the default language to French from English, and I even tried it with the Bridge theme (The theme that you use), but I can not replicate this behavior.
I'm not getting the -en added to the slug of the category.

At this point, I think it would be better if I take a look at the back-end of your site.
Please, read and approve the following.
I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.
For this, I'll need to install the Duplicator plugin on your site.
https://wordpress.org/plugins/duplicator/

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Thanks,
Itamar.

April 16, 2017 at 3:15 pm #1254996

manonv

Oh sorry, the username for logging in on wordpress is without .com on the end

April 17, 2017 at 2:18 pm #1255321

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Itamar is off today. If you don´t mind, I will take care of this ticket.

I read the whole thread carefully, but I may miss something. If so, please be patient 🙂 and let me know if I'm not getting the point.

If I understood properly you want to have the same slug for the original and translated category, right?

This is not possible, let me try to make clear why it is not.

Original and translated categories are in fact two categories. If you deactivate WPML, you will see it clearly. Both categories will remain but without language information nor connection.

And WordPress itself does not allow two categories with the same slug.

We had a bug a few versions ago that allowed it, but it generated other problems. The right thing is that each category has a different slug.

I'm not sure what is happening with the first site you showed us. Maybe that bug, maybe some custom coding (which is outside of the scope of our support). But I checked, double checked and triple checked and it is not possible to have the same slug for original and translated categories.

The second site is a page, not a category.

Please, let me know if my explanation was clear enough and if there is anything else I can do for you.

Kind Regards,

Otto

April 17, 2017 at 2:38 pm #1255332

manonv

Hi Otto,

Thank you for your reply.
I knew that the same slug for the original and translated category wasn't possible, but I was confused when I saw that website in my first example.
But I was wondering: what did Itamar meant when he said that WPML can translate the category's terms? I didn't quite understand that. He said:
"Nevertheless, WPML can translate the category's terms.
In your case, 'europe' is the category's name and 'netherlands' (for example) is the category's term.
Please, correct me if I'm wrong.
When translating the categories' terms, you can leave it the same as the original."

And he said that that's the case with the website from my example.

Can you explain this a bit for me maybe?

Thank you!

April 17, 2017 at 2:38 pm #1255333

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi again 🙂

Please hold, I'm quadruple checking. There is hope!

I'll get back to you when I have more information about the issue.

Kind Regards,

Otto

April 18, 2017 at 12:56 pm #1256026

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi there!

Thanks for your patience.

This needs to be investigated further but I found a workaround to accomplish what you need.

If instead of editing the category you use the quick edit link you will be able to change the slug of the category.

Please take a look at this screencast:
hidden link

Let me know if it works for you and if this is a suitable solution for now.

Kind Regards,

Otto

April 19, 2017 at 3:50 am #1256591

manonv

That worked!
Thank you very much for the solution and your help!
Really appreciated.

Kind Regards,
Manon