Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Alejandro 1 month ago.

Assigned support staff: Alejandro.

Author Posts
May 7, 2021 at 12:25 pm #8713939

laetitiaL-6

Hello,
I saw the problem with Carlos Rojas about 30 minutes ago:
Some texts on my site do not display in English or very poorly. He added a bit of code to the WPML plugin, but that doesn't solve a problem.
Thank you.

May 8, 2021 at 9:59 am #8719393

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi there, may i have more details on the following:

- can you let me know what strings specifically have the issue

- you mean that they are either not translated OR "translated poorly", what do you mean by this, how can it be "translated poorly"?

- Where are these strings coming from? a plugin, a theme setting?

May 10, 2021 at 6:41 am #8725641

laetitiaL-6

Some strings are not translated into English, others I have the html code which is displayed in front when it should not ...
Your colleague Carlos Rojas helped me, he put a piece of XML code to have Blurb elements detected by WPML. I don't know what to tell you other than seeing the problem directly on the site by giving you login details or talking by chat like I did with Carlos. This is a fairly urgent problem because my client is waiting for his website.

As an attachment, I send you the visible concerns.

prob-wpml.jpg
May 10, 2021 at 9:20 am #8727195

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Could you please allow me access to the site so i can check what's going on?

Also, please refer me to the page where the problem is happening and allow me access to the site so i can take a closer look at the problem, please

I have enabled the credential fields for your next answer. please add everything there so it remains safe and private.

Regards.

May 10, 2021 at 10:42 am #8727925

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

The problem seems to come from DIVI itself as you can see here: hidden link

Divi seems to strip the HTML structure and shows it as if it was "normal" content and not HTML tags, so WPML recognizes it in the same way.

Can you please ask them to check this out and try to fix it of possible to see if the problem continues with WPML (you'll have to edit the title, change it a bit and then save the page to force a new translation update in order to verify if the problem is solved)?

May 10, 2021 at 12:17 pm #8728807

laetitiaL-6

Thank you i will watch this

May 10, 2021 at 12:46 pm #8729021

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sure. i'll leave the ticket open for 14 more days in case you need anything else from us. please let us know how it goes.

Regards.

The topic ‘[Closed] same unresolved issue: English translation not showing’ is closed to new replies.