Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Shekhar Bhandari 2 years, 2 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 17, 2018 at 3:45 pm

Karl

when saving page, from the translation editor, the screen keeps saying: 'saving...'
takes about a minute (see screenshot) before it eventually closes the page as being saved

I have all plugins disabled except wmpl and beaver plugins
memory setting: 512MB

May 21, 2018 at 9:32 am #2200077

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

It seems like a theme/plugin conflict or a PHP error that is blocking some functionalities and creating such issues, so could you please perform the below steps and let me know if that helps?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

May 21, 2018 at 9:55 am #2200105

Karl

Hi

Switched to Twenty Eleven theme and jut enabled WPML plugins.
Saving page looks much faster now.

Re-enabling only the Beaver Builder plugin makes the problem occur again.

Please find debug.log info below:

[21-May-2018 09:52:55 UTC] PHP Notice: Undefined property: stdClass::$post_type in /var/www/clients/client156/web510/beezz/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 1361
[21-May-2018 09:52:55 UTC] PHP Stack trace:
[21-May-2018 09:52:55 UTC] PHP 1. {main}() /var/www/clients/client156/web510/beezz/wp-admin/edit.php:0
[21-May-2018 09:52:55 UTC] PHP 2. require_once() /var/www/clients/client156/web510/beezz/wp-admin/edit.php:303
[21-May-2018 09:52:55 UTC] PHP 3. do_action() /var/www/clients/client156/web510/beezz/wp-admin/admin-header.php:142
[21-May-2018 09:52:55 UTC] PHP 4. WP_Hook->do_action() /var/www/clients/client156/web510/beezz/wp-includes/plugin.php:453
[21-May-2018 09:52:55 UTC] PHP 5. WP_Hook->apply_filters() /var/www/clients/client156/web510/beezz/wp-includes/class-wp-hook.php:310
[21-May-2018 09:52:55 UTC] PHP 6. SitePress->post_edit_language_options() /var/www/clients/client156/web510/beezz/wp-includes/class-wp-hook.php:286
[21-May-2018 09:52:55 UTC] PHP Notice: Undefined property: stdClass::$post_type in /var/www/clients/client156/web510/beezz/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 1412
[21-May-2018 09:52:55 UTC] PHP Stack trace:
[21-May-2018 09:52:55 UTC] PHP 1. {main}() /var/www/clients/client156/web510/beezz/wp-admin/edit.php:0
[21-May-2018 09:52:55 UTC] PHP 2. require_once() /var/www/clients/client156/web510/beezz/wp-admin/edit.php:303
[21-May-2018 09:52:55 UTC] PHP 3. do_action() /var/www/clients/client156/web510/beezz/wp-admin/admin-header.php:142
[21-May-2018 09:52:55 UTC] PHP 4. WP_Hook->do_action() /var/www/clients/client156/web510/beezz/wp-includes/plugin.php:453
[21-May-2018 09:52:55 UTC] PHP 5. WP_Hook->apply_filters() /var/www/clients/client156/web510/beezz/wp-includes/class-wp-hook.php:310
[21-May-2018 09:52:55 UTC] PHP 6. SitePress->post_edit_language_options() /var/www/clients/client156/web510/beezz/wp-includes/class-wp-hook.php:286
[21-May-2018 09:54:12 UTC] PHP Notice: Undefined property: stdClass::$post_type in /var/www/clients/client156/web510/beezz/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 1361
[21-May-2018 09:54:12 UTC] PHP Stack trace:
[21-May-2018 09:54:12 UTC] PHP 1. {main}() /var/www/clients/client156/web510/beezz/wp-admin/edit.php:0
[21-May-2018 09:54:12 UTC] PHP 2. require_once() /var/www/clients/client156/web510/beezz/wp-admin/edit.php:303
[21-May-2018 09:54:12 UTC] PHP 3. do_action() /var/www/clients/client156/web510/beezz/wp-admin/admin-header.php:142
[21-May-2018 09:54:12 UTC] PHP 4. WP_Hook->do_action() /var/www/clients/client156/web510/beezz/wp-includes/plugin.php:453
[21-May-2018 09:54:12 UTC] PHP 5. WP_Hook->apply_filters() /var/www/clients/client156/web510/beezz/wp-includes/class-wp-hook.php:310
[21-May-2018 09:54:12 UTC] PHP 6. SitePress->post_edit_language_options() /var/www/clients/client156/web510/beezz/wp-includes/class-wp-hook.php:286
[21-May-2018 09:54:12 UTC] PHP Notice: Undefined property: stdClass::$post_type in /var/www/clients/client156/web510/beezz/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 1412
[21-May-2018 09:54:12 UTC] PHP Stack trace:
[21-May-2018 09:54:12 UTC] PHP 1. {main}() /var/www/clients/client156/web510/beezz/wp-admin/edit.php:0
[21-May-2018 09:54:12 UTC] PHP 2. require_once() /var/www/clients/client156/web510/beezz/wp-admin/edit.php:303
[21-May-2018 09:54:12 UTC] PHP 3. do_action() /var/www/clients/client156/web510/beezz/wp-admin/admin-header.php:142
[21-May-2018 09:54:12 UTC] PHP 4. WP_Hook->do_action() /var/www/clients/client156/web510/beezz/wp-includes/plugin.php:453
[21-May-2018 09:54:12 UTC] PHP 5. WP_Hook->apply_filters() /var/www/clients/client156/web510/beezz/wp-includes/class-wp-hook.php:310
[21-May-2018 09:54:12 UTC] PHP 6. SitePress->post_edit_language_options() /var/www/clients/client156/web510/beezz/wp-includes/class-wp-hook.php:286

May 22, 2018 at 8:38 am #2205929

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Switched to Twenty Eleven theme and jut enabled WPML plugins.
Saving page looks much faster now.

Performance issues depend upon the site, it's server, plugins used and furthermore, I agree that multilingual plugins take more resources than other plugins as it needs to connect all plugins/themes strings and translate them accordingly. So, the fact is that if you have more plugins and themes (with a large number of strings) WPML will try to translate them which adds significant load and you will feel the performance issue, which is normal somehow.

In every update, we are trying to increase the performances of our plugins.

Further, here are a few things you can try to increase the site performance:
http://wpml.org/2012/01/can-your-site-run-faster/
http://wpml.org/faq/why-string-translation-appears-to-slow-down-sites/

Let me know if this helps.

Thanks

The topic ‘[Closed] saving from beaver Builder translation window takes very long’ is closed to new replies.