This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Saving results in error 502

Solution: The translation of the page was in trash and wasn't deleted properly as a reason the issue was happening, deleting the page from trash solved the issue.

This topic contains 8 replies, has 2 voices.

Last updated by Malene 4 weeks, 1 day ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 16, 2019 at 2:05 pm #4581057

Malene

I am trying to: Save a page

Link to a page where the issue can be seen: hidden link

I expected to see: a Saved page

Instead, I got: Error 502

September 17, 2019 at 2:42 am #4585033

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Since this type of issues can be created by some conflicts or php errors. I would need your help to narrow down the issue. Could you please provide feedback on the following questions as much as possible?

#1
Can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

#2
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

#3
Also you can contact your host and ask for suggestions regarding the error as well as server error log file that can help here to understand the issue.

Thank you for helping us to pinpoint the issue. Feel free to add any further information you may have.

Look forward to your reply.

Thanks

September 17, 2019 at 8:13 am #4586265

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

What's the results of #1, is the problem still happening when all plugins are disabled except WPML.

Can you go to Dashboard->Updates and re-install the WordPress By clicking re-install now? Please make a backup before proceeding.

Let me know if this helps.

Thanks

September 17, 2019 at 8:33 am #4586425

Malene

Regarding #1, the issue still remains.
Regarding reinstalling WP, this did not solve the issue.

September 17, 2019 at 9:11 am #4586875

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Can you disable WPML for a moment and see if the problem exists?

If the problem exists, to further debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

September 18, 2019 at 5:43 am #4592597

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the details.

Could you contact your hosting provider and ask for the server logs? this will help us to narrow down the issue.

Thanks

September 19, 2019 at 7:13 am #4601865

Malene

The site is now migrated, and the error still persists.

September 20, 2019 at 3:16 am #4609115

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The translation of the page is in trash and isn't deleted properly as a reason the issue is happening, can you please delete the translation from the trash and see if that helps?

If the problem still exists, I request you to check the dashboard->pages for the pages with ID 44, there must be 2 pages with same id so you should delete the one page, publish it and continue.

Let me know if this helps.

Thanks

September 20, 2019 at 10:46 am #4611547

Malene

My issue is resolved now. Thank you!