This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Riffaz 4 months ago.

Assigned support staff: Riffaz.

Author Posts
May 30, 2019 at 11:15 am #3922493

hiroakiH

Tell us what you are trying to do?
・We want to translate theme and plugin. So we want to use "Scanning themes for texts" to find string. however, clicking on "Scanning themes for texts" button won't complete the scan. please find attached capture.

Is there any documentation that you are following?
No

Is there a similar example that we can see?
Please find below
hidden link

What is the link to your site?
hidden link

May 30, 2019 at 11:24 am #3922549

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

There could be many reasons for this.

Please provide WPML Debug info for better and faster support:https://wpml.org/faq/provide-debug-information-faster-support/

I am enabling the debug info box for next reply.

Let's check one by one.

Regards,
Riffaz.

May 31, 2019 at 4:09 am #3927643

hiroakiH

Hi WPML Support team,

Thank you for your support.
I attached WPML debug data. please confirm it.
if you need more information, please contact me.

Regards,

May 31, 2019 at 5:07 am #3927771

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

Your WP Memory is 40Mb which is not enough: hidden link
Please increase it to 512MB as your server /hosting package allows you to increase it upto 512mb.

Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '512M');

Also, increase your MaxInputVars to 10000 and check the issue again.

Let me know how it goes.

Regards,

June 10, 2019 at 5:03 am #3985171

hiroakiH

Hi Riffaz,

Sorry for the late reply. and thank you for continue support.

We increased WP memory to 512MB from 40MB.
Also, increased Max_Input_Vars to 1000 from 10000. but, this issue is continuing.
Can you suggest us other solutions?

Regards,

June 10, 2019 at 6:25 am #3985353

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Maybe you are facing this issue because of compatibility issues. So to make sure if possible, please do the following steps.

Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here : hidden link and let me know.

Plugin conflict
Could you please disable all the plugins and check this?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes like twenty seventeen, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

June 11, 2019 at 1:57 pm #3995831

hiroakiH

Hi Riffaz,

Thank you for your support.
I update for this issue. please conform delow.

Console Errors
→I confirmed it. there is no console error.

Plugin conflict & Minimal Setup
→We have any original plugin.
We can not access WordPress[devn.yattare.jp] when we disable the original plugin. So we can't disable all plugin.

Debugging
→I provide debug log. please see below.

Note:
"claw" is original plugin. the database name has been changed for original plugin.
"データベースエラー" is database error.

debug.log
-----------------------------------------------------------------------------------------------------
WordPress database error: [Table 'wp_claw_options' is marked as crashed and should be repaired]
SELECT option_value FROM wp_claw_options WHERE option_name = '_transient_wpml_st_upgrade_in_progress' LIMIT 1

WordPress database error: [Duplicate entry '_transient_wpml_st_upgrade_in_progress' for key 'option_name']
INSERT INTO `wp_claw_options` (`option_name`, `option_value`, `autoload`) VALUES ('_transient_wpml_st_upgrade_in_progress', '1', 'no') ON DUPLICATE KEY UPDATE `option_name` = VALUES(`option_name`), `option_value` = VALUES(`option_value`), `autoload` = VALUES(`autoload`)

WordPress database error: [Table 'wp_claw_options' is marked as crashed and should be repaired]
SELECT autoload FROM wp_claw_options WHERE option_name = '_transient_wpml_st_upgrade_in_progress'

Notice: Constant WP_MEMORY_LIMIT already defined in /home1/yattare/www/public_html/wp-config.php on line 110
WordPress データベースエラー: [Table 'wp_claw_options' is marked as crashed and should be repaired]
SELECT option_value FROM wp_claw_options WHERE option_name = '_site_transient_update_themes' LIMIT 1

Notice: Undefined property: stdClass::$option_value in /home1/yattare/www/public_html/wp-includes/option.php on line 95
WordPress データベースエラー: [Table 'wp_claw_options' is marked as crashed and should be repaired]
UPDATE `wp_claw_options` SET `option_value` = 'O:8:\"stdClass\":1:{s:12:\"last_checked\";i:1560258738;}', `autoload` = 'no' WHERE `option_name` = '_site_transient_update_themes'

WordPress データベースエラー: [Table 'wp_claw_options' is marked as crashed and should be repaired]
UPDATE `wp_claw_options` SET `option_value` = 'O:8:\"stdClass\":4:{s:12:\"last_checked\";i:1560258739;s:7:\"checked\";a:4:{s:4:\"claw\";s:3:\"0.1\";s:13:\"twentyfifteen\";s:3:\"1.7\";s:15:\"twentyseventeen\";s:3:\"1.2\";s:13:\"twentysixteen\";s:3:\"1.3\";}s:8:\"response\";a:3:{s:13:\"twentyfifteen\";a:6:{s:5:\"theme\";s:13:\"twentyfifteen\";s:11:\"new_version\";s:3:\"2.5\";s:3:\"url\";s:43:\"https://wordpress.org/themes/twentyfifteen/\";s:7:\"package\";s:59:\"hidden link\";s:8:\"requires\";s:3:\"4.1\";s:12:\"requires_php\";s:5:\"5.2.4\";}s:15:\"twentyseventeen\";a:6:{s:5:\"theme\";s:15:\"twentyseventeen\";s:11:\"new_version\";s:3:\"2.2\";s:3:\"url\";s:45:\"https://wordpress.org/themes/twentyseventeen/\";s:7:\"package\";s:61:\"hidden link\";s:8:\"requires\";s:3:\"4.7\";s:12:\"requires_php\";s:5:\"5.2.4\";}s:13:\"twentysixteen\";a:6:{s:5:\"theme\";s:13:\"twentysixteen\";s:11:\"new_version\";s:3:\"2.0\";s:3:\"url\";s:43:\"https://wordpress.org/themes/twentysixteen/\";s:7:\"package\";s:59:\"hidden link\";s:8:\"requires\";s:3:\"4.4\";s:12:\"requires_php\";s:5:\"5.2.4\";}}s:12:\"translations\";a:1:{i:0;a:7:{s:4:\"type\";s:5:\"theme\";s:4:\"slug\";s:13:\"twentysixteen\";s:8:\"language\";s:2:\"ja\";s:7:\"version\";s:3:\"1.3\";s:7:\"updated\";s:19:\"2017-11-14 13:20:55\";s:7:\"package\";s:74:\"hidden link\";s:10:\"autoupdate\";b:1;}}}', `autoload` = 'no' WHERE `option_name` = '_site_transient_update_themes'
-------------------------------------------------------------------------------------------------------

June 13, 2019 at 5:08 am #4009507

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

Your database is corrupted.
Do you familiar with repairing tables hidden link ?

If yes, please take full back up of your site and database, then repair the table.
If you are not familiar let us know.

Regards,

The topic ‘[Closed] Scanning themes for texts does not complete’ is closed to new replies.