Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Diego Pereira 2 years ago.

Assigned support staff: Diego Pereira.

Author Posts
August 31, 2018 at 7:45 pm

Daniel Romangoli

I am translating a site that's almost ready to publish. What I have noticed is that there's additional spacing showing in the screenview to the right. Since this only happens to translated pages, I think it has something to do with WPML.

Link to a page where the issue can be seen: hidden link

I expected to see no scroll to the right....

August 31, 2018 at 8:21 pm #2695031

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @danielr-72, welcome to the WPML support Forum!

I noticed that you are using the divi theme. Apparently it's a CSS conflict or theme setting. Please go to Divi> Theme Options, Modify the language using the language switcher at the top admin bar and check out the theme options in the translation.

A workaround is to fix it using CSS. You can add this snippet to Appearance > Customize > Additional CSS:

@media (min-width: 1140px) {
html body {
    overflow-x: hidden !important;
}
}

If you need more help just let me know.

All the best,
Diego

September 4, 2018 at 1:04 pm #2703420

Daniel Romangoli

Yeah, I'm using Divi. Added the code into additional CSS but I'm still getting the extra spacing.

September 4, 2018 at 6:27 pm #2704365

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

The blanks space has disappeared on my computer (see screenshot).

Could you take another look? Please clear all caches and test it from a incognito mode tab (ctrl + shift +n on chrome).

If you need more help just let me know.

Regards,
Diego

September 4, 2018 at 6:50 pm #2704480

Daniel Romangoli

It appears to have gone, but if you try to scroll to the right it still scrolls

September 5, 2018 at 1:20 pm #2707249

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I tested again. it's not possible to scroll to the side because the horizontal scroll bar does not appear.

What browser and resolution are you using? I tested the desktop version in the chrome and firefox browsers.

Please clear all caches and test again using the incognito mode of your browser. perhaps it's a caching issue.

Regards,
Diego