Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bruno 1 year, 1 month ago.

Assigned support staff: Bruno.

Author Posts
October 8, 2018 at 5:04 pm #2796998

marcoc-68

the wrong site pops up: hidden link

I expect to see: hidden link

So that lang=en messed up everything. Why? how to solve that issue?

thanks
marco

October 9, 2018 at 6:09 pm #2801511

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

This is because the search form is not setting the language. You can see step by step in our documentation about how to include the language in the search form code: https://wpml.org/documentation/support/creating-multilingual-wordpress-themes/search-form/

Another way to solve the problem should be to use the URL format for language as directories. To do this, follow the steps below:

- Click on the WPML > Languages > Language URL format
- Select the "Different languages in directories" option
- Click on the Save button

Following the steps above should work properly too. Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

October 10, 2018 at 7:50 pm #2805641

marcoc-68

Dev of theme .. is trying to fix it. Once it's fixed, I will notify you.
Thanks so far.

October 10, 2018 at 10:16 pm #2805929

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thanks for the feedback. Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.