This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Bruno 3 months ago.

Assigned support staff: Bruno.

Author Posts
July 18, 2019 at 5:30 pm #4241421

malekA

I am trying to: when click enter on a search it goes to main language not the translated language even though the page does exist.

Link to a page where the issue can be seen: hidden link

I expected to see:

Instead, I got:

July 18, 2019 at 9:30 pm #4242449

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. This seems to happen because the form is receiving the default language URL in the language code.

One way you'll fix this will be to use directories as URL format, rather than using the language as a parameter. To test this, please follow the steps below:

- Click on the WPML > Languages > Language URL format
- Select the "Different languages in directories" option
- Click on the Save button
- Clear your site's cache

Test and verify that the search is working correctly in both languages.

Thank you.

The topic ‘[Closed] Search function not translating’ is closed to new replies.