Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 -
- 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 -

Supporter timezone: Europe/Bucharest (GMT+03:00)

This topic contains 1 reply, has 2 voices.

Last updated by Radu 1 year, 3 months ago.

Assigned support staff: Radu.

Author Posts
November 4, 2021 at 4:14 am #9922029

chloeS-2

I am trying to:
Translate the placeholder text "Search" into Spanish in the header for both desktop and mobile versions. I saw this post from 2017 (https://wpml.org/forums/topic/how-do-i-translate-the-default-wordpress-search-form/), but WordPress has changed a lot and I attempted following the steps but with no luck. Also tried adding text in the header as well to see if that area in the header can be translated, maybe it's only navs and content-sections that can be translated or simply certain parts that are connected to the theme, nothing custom?

This article
https://wpml.org/forums/topic/wpml-does-not-show-any-string-for-translations/#post-1353067
- References using "<?php echo esc_attr__('the_string','the_text-domain'); ?>"

But in the source code have this "<?php esc_attr__( 'Search', 'twentytwelve' ); ?>"
- Which looks the extact same but it doesn't work.

Link to a page where the issue can be seen:
hidden link (selecting in Chrome to translate the page to Spanish)

I expected to see:
"Search" the placeholder text translate when the translation is done.

Instead, I got:
Nothing has been translated yet. "Search" is listed in the words that can be translated but it doesn't work.

November 4, 2021 at 9:50 am #9923639

Radu

Hey Chloe,

Thank you for reaching out to the WPML support!

Can you go to WPML → Theme and plugins localization and scan the theme or plugin that contains this string, then go to WPML → String Translation and look again for this string, please? Once you translate it, everything should work fine on the front-end.

If this doesn't work, please follow these steps too:

  • go to WPML → String Translation;
  • scroll down the page and enable the Look for strings while pages are rendered option;
  • go to the page where the Search text is visible and refresh the page;
  • go back to WPML → String Translation;
  • disable the Look for strings while pages are rendered option;
  • look again for the Search text in WPML → String Translation area and translate it.

As I can see, the WP memory limit on your website is 40M. Can you increase it to 128M (256M recommended - https://wpml.org/home/minimum-requirements/), please?
You can have a look at this article to find out how to make this change:
hidden link

Thanks,
Radu

The topic ‘[Closed] "Search" placeholder text isn't translating’ is closed to new replies.