This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Itamar 2 months, 4 weeks ago.

Assigned support staff: Itamar.

Author Posts
July 18, 2019 at 8:49 am

cyrusB

I am trying to:
View Search results in German language

Link to a page where the issue can be seen:
hidden link
I expected to see:
German serp listing
Instead, I got:
hidden link
English meta descriptions and titles in serps

July 18, 2019 at 9:36 am
July 18, 2019 at 9:36 am
July 18, 2019 at 3:11 pm #4240055

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

The chat probably got disconnected so I'll continue to handle this issue. I hope that it is OK with you.

You have the option 'Redirect visitors based on browser language only if translations exist' in WPML -> Languages -> Browser language redirect enabled. This is known to make such problems as you are experiencing. We mention it when you enable this option and also you can read about it in our documentation here.
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/

To solve this problem please do the following.
1. Disable the browser redirect option.
2. Make sure that you have a sitemap on your site.
3. Make sure that all the SEO metadata is translated.
4. Clear all the cache from your site.
5. Go to Google console and ask for your site to be re-indexed.

Then after a while, you should see the correct results.
Please let me know if this information is helpful to you.

Regards,
Itamar.

July 18, 2019 at 3:41 pm #4240257

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

I'll wait for your reply.

Cheers,
Itamar.

The topic ‘[Closed] Search Result pages ALWAYS show the wrong language descriptions’ is closed to new replies.