This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by floraP 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
October 11, 2018 at 7:51 am #2807035

floraP

Hello,

The results of the translated greek page are not showed up (categories, location, key-words), as it happens with english results.

Following advices from other supported tickets, i cleaned up the followings in Troubleshooting:
- Clear the cache in WPML
- Remove ghost entries from the translation tables

Finally, without results. Please see the related video hidden link, where i searched for a location in translated page without results and i found results for the same location in english language.

Could you help me, please?

October 11, 2018 at 4:32 pm #2809130

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @florap, welcome to the WPML support Forum!

Is the search form generated by the theme or it's custom coded? What is the theme name? This could be a compatibility issue.

Please take a look at this article: https://wpml.org/documentation/support/creating-multilingual-wordpress-themes/search-form/

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.
NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

All the best,
Diego

October 11, 2018 at 7:34 pm #2809621

floraP

Hello Diego,

Yes right, the search box comes from the ''JobCareer'' theme. You could find it at: ''Jobs'', '' Home'' and ''Search Result'' pages.

After reading the suggested documentation, i have added this code into the search box page: <input type="hidden" name="lang" value="gr"/>, but it did not work.

Thank you.

October 12, 2018 at 3:06 pm #2812389

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I will keep Diego's place as he is off today.

I will need your written approval for us to be able to log into the backend of your site using the credentials you shared in the other tickets so that we can look at the edits you've made.

Also, can you please let me know how we can get to the exact place that you talk about here "i have added this code into the search box page"?

I will be waiting for your response.

Kind regards,
Mihai

October 12, 2018 at 3:41 pm #2812479

floraP

Hello Mihai,

You can use my credentials and log in to my account.

I have added the code in the page ''Αρχική Σελίδα'', which is the translated page of ''Home'' page. The ''job search'' element does not has an option to add this code into it, so i added it in the text. I am attaching a photo for this .

Thank you.

October 15, 2018 at 5:20 pm #2818440

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

As this seems to be a compatibility problem, I think it's best to try to reproduce the problem in a clean installation. So we can do some testing without modifying your website, and if necessary, forward it to our compatibility team.

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the JobCareer theme to this test install and setup it the same way as in your website (using the same options). Please note that we only need the theme, the related functionality and some dummy content to reproduce the issue. You don't need to setup a entire website or clone your existing site.

Kind regards,
Diego

October 16, 2018 at 12:28 pm #2820920

floraP

Dear Diego,

I have installed the theme in the test site.

When i add a keyword or a specialism in the greek search box, the results show up properly. When i do the same for locations, i do not get any results.

Please guide me to solve this issues on my website.

Thank you.

October 16, 2018 at 1:34 pm #2821132

floraP

My issue is resolved now. Thank you!