This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.73 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: Atelier theme search in the top menu redirects to default language Solution: https://wpml.org/forums/topic/mobile-search-not-working/#post-3106858

This topic contains 5 replies, has 2 voices.

Last updated by franciscusR 1 week, 4 days ago.

Assigned support staff: Bruno Kos.

Author Posts
October 1, 2019 at 9:03 am #4669869

franciscusR

I am trying to: When I am switching from Dutch (default) to my English website and try to search a product (Mad Dog) and hit enter, then my results will be in Dutch. This does not happen when I type Mad Dog in the search bar and click "show all results" with my mouse. Then it shows English results, just as I wanted.

Link to a page where the issue can be seen: Entire website

I expected to see: English search results

Instead, I got: Dutch search results.

October 1, 2019 at 11:59 am #4671825

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Do you have a staging site perhaps, development site clone' Because I am unable to create a Duplicator package, it got stuck:
hidden link

Regards,
Bruno Kos

October 1, 2019 at 12:01 pm #4671833

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Actually, hold on a bit, it got unstuck, perhaps it goes get through after a couple of hours or so :).

Regards,
Bruno Kos

October 2, 2019 at 10:35 am #4679159

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you check this answer?
https://wpml.org/forums/topic/mobile-search-not-working/#post-3106858

Regards,
Bruno Kos

October 8, 2019 at 7:15 am #4712727

franciscusR

Thanks for the help!

October 10, 2019 at 12:20 pm #4730111

franciscusR

Hi Bruno.

I am seeing other strange things happening since we have been trying to solve the problem above. When I am searching for certain products (such as Hellfire) than I often see two versions of the same product in the search outcomes. I found out that 1 is the Dutch version of the product and the copy is the English version of the product. You have installed the Duplicator plugin on my website, could that cause this?