This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Noman 2 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
August 4, 2019 at 2:48 pm #4336575

michaelP-15

I am trying to: Make a search in Spanish

Link to a page where the issue can be seen:sucre.net

I expected to see: Buscar

Instead, I got: Search

Hi, I was looking for a way to stop the search results appearing in English when in Spanish and found this topic https://wpml.org/forums/topic/search-results-are-not-in-the-current-language-2/ which solves the problem.

However, words like search, read more, etc are still appearing in English.

You must scroll down the page a little to get the search bar to appear.

How can we translate these words to Spanish?

Many thanks,

Mike

August 4, 2019 at 5:20 pm #4336737

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

=== Please backup your database and website ===

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

2. Please upgrade your server’s PHP version to a higher level: https://wpml.org/home/minimum-requirements/

PHP is 5.6.40 which is good, but it's advised is to use more up-to-date version for better performance and stability. You can contact your website hosting company to upgrade this for you.

3. You are using an older version of WordPress on your site, please backup your site and update WordPress to it’s latest version 5.2.2.

4. You are using an older version of WPML plugins. Please backup your site and update ALL WPML plugins to it's latest versions. You can download it from your account: https://wpml.org/account/downloads/

5. Please make sure you are using latest version of your theme.

6. Could you please try to find those strings in string translation by doing below steps:
- Go to WPML >> String Translation.
- Click the link 'Translate texts in admin screens »' (you'll find it at the bottom of the page)
- You'll see a page with a large list of text strings. These are all the registered Admin options. Try to find your required string field here. Take in mind that it can be inside a theme section (for example: RealHomes). If so, try to click the link to check all its options. If you find your option there, select it marking its checkbox and click the Apply button (bottom of the page)
- Once done you should see the string registered in WPML >> Strings Translation. Then you'll simply need to translate it and mark it as complete.

Here is doc:
https://wpml.org/documentation/getting-started-guide/string-translation/

Thank you

The topic ‘[Closed] Search text appaering in English not Spanish’ is closed to new replies.