This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Ahmed Mohammed 4 years, 11 months ago.

Assigned support staff: Ahmed Mohammed.

Author Posts
August 30, 2014 at 3:08 pm #460407

Bryan

I am trying to: do a basic search

I visited this URL: hidden link

I expected to see: Searches in Japanese when Japanese is selected found, not my searches sent to the english page.

Instead, I got: No result found in English

I ran up this site ONLY to prove this issue
Disabling WPML finds any search term I try...
I added french and get the same result...

please fix it

This has been a BUG for about 3 years - and wasted 3 hours of my time tonight, and from the look of the forum thousands of hours for many people since 2009.

September 1, 2014 at 10:55 am #461001

Ahmed Mohammed
Supporter

Timezone: Europe/Rome (GMT+02:00)

Thanks for contacting us, I'll help in this.

As a quick test, can you please try this.

Go to your WP Dashboard -> WPML -> Languages -> Language URL format and enable "Different languages in directories" and check the search function if it is working on your website as it supposed or not.

Thanks!

The topic ‘[Closed] Searches go to English and not target language’ is closed to new replies.