Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Pierre 6 years, 6 months ago.

Assigned support staff: sarah.n.

Author Posts
February 22, 2013 at 12:04 am #106358

Vincent

This is a brand new install on domaineducoteau.com
WordPress 3.5.1
WPML 2.6.4.1
WPML Media 1.2.3

The media library in french was working great but on adding a media file to French first, the media library stopped displaying any files when clicking Add Media. Media management in french still works fine from the admin menu. It is like the add button in french can't find its own library.

February 22, 2013 at 7:56 am #106419

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Vincent,

Please go under "WPML -> Support -> Troubleshooting" and from within "WPML settings" search for [custom_posts_sync_option]

Can you please copy and paste what you have inside that array?

February 22, 2013 at 2:50 pm #106587

Vincent

[custom_posts_sync_option] => Array
(
[wpcf7_contact_form] => 1
[feedback] => 1
[safecss] => 1
[attachment] => 1
)

February 25, 2013 at 11:27 am #106970

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Thank you Vincent.

Now this is what I would like you to do.

1. Go to your Media Library and locate an image file. Click on "Edit" to go to the "Edit Media" screen of this file.

2. Scroll all the way to the bottom of the page and look for the "Make 'Media' translatable" checkbox.

3. It should be disabled. If it is already disabled, enable it first the save. Next disable it and save again. This will cause WPML to re-save its settings.

4. Visit the "WPML settings" ("WPML -> Support -> Troubleshooting") again and search for [custom_posts_sync_option] you'll see that [attachment] is on 0 as it should be*.

* It should be either on 0 or not there at all!

Let me know whether the above fixes the problem.

February 26, 2013 at 12:18 am #107139

Vincent

All fixed thank you

February 26, 2013 at 9:18 am #107207

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

You are welcome 🙂

May 21, 2013 at 5:34 pm #129141

Pierre

Hi, help, this doesn't work:

3. It should be disabled. If it is already disabled, enable it first the save.

>>> chekbox is allways unchecked
Next disable it and save again. This will cause WPML to re-save its settings.

4. Visit the "WPML settings" ("WPML -> Support -> Troubleshooting") again and search for [custom_posts_sync_option] you'll see that [attachment] is on 0 as it should be*.

How change [attachment] => 1 to [attachment] => 0

Thanks

May 21, 2013 at 6:28 pm #129158

Pierre

Sorry, all its right, ' il faut être sur la langue de référence du site et non une langue secondaire'