This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by natalieR-4 1 month, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 27, 2019 at 4:06 pm #4468389

natalieR-4

Hi,
After receiving a fatal error when trying to activate my plugin I submitted a ticket last week and I was instructed to do the following:

1 - In your WordPress Dashboard > Plugins delete your current WPML Multilingual CMS plugin files and upload a fresh downloaded copy of it from your wpml.org account.

2 - Disable all the plugins and try to activate the WPML Multilingual CMS and run its setup wizard.

3 - Once it is finished activate all the other plugins one by one.

I was able to activate the plugin and everything seemed ok however I just noticed that the French version of the secondary menu is not linking properly. The 1st 4 links (Joey Savoie, Équipe, Nouvelles, Connect) are all going to an event on the English side instead (hidden link)

Can you help me figure out how to get these links to work please?
Thank you!

August 27, 2019 at 6:54 pm #4469171

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I took a detailed look in your website and could notice your links are pointing to anchors sections in your content instead of a new existing page, I recommend you to go to your WordPress Dashboard > Appearance > Menus and manually adjust the links of the translated secondary menu to point to right places, for example instead of 'hidden link; it should be 'hidden link;.

Please, let me know if it works for you or if you need any additional details and clarifications, have a nice day.

August 28, 2019 at 1:25 pm #4474611

natalieR-4

Hello,
I manually changed the links as you suggested but now each of the links just takes me back to the English homepage. Any ideas? Thanks very much!

August 28, 2019 at 2:24 pm #4475123

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 28, 2019 at 6:54 pm #4476549

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look in your website and could confirm the issue, it seems to be related with a limitation of the language url format currently used in your website. I recommed you to try the following:

1 - In your WordPress Dashboard > WPML > Languages > Language URL format change your current option to the 'Different languages in directories' choice.

2 - Resave your permalinks from your WordPress Dashboard > Settings > Permalinks.

See: https://wpml.org/faq/server-setting-for-languages-in-directories/

3 - Update your translated secondary language menu with the update url structure, something like 'hidden link' for your translated page. Note here you should use the same IDs you used in your default language page, for example you should use 'bio' instead of 'biographie'.

Please, let me know if it works this time. Have a nice day.

August 28, 2019 at 7:06 pm #4476661

natalieR-4

My issue is resolved now. Thank you!