Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
The client was unable to translate a link within a section using the Divi theme, as it was not appearing in the WPML Translation Editor.
Solution:
We found that the Translation support for the Link field in the Divi theme had not been implemented. To resolve this, we added custom XML configuration to the WPML settings to register the link field for translation. Here is the code to insert into the "WPML > Settings > Custom XML Configuration" section:

<wpml-config><br />  <shortcodes><br />    <shortcode><br />      <tag>et_pb_section</tag><br />      <attributes><br />        <attribute>link_option_url</attribute><br />      </attributes><br />    </shortcode><br />  </shortcodes><br /></wpml-config>

Additionally, if you encounter any Divi modules not displaying translated content, we recommend checking the following documentation to ensure the module is registered for translation:

If the solution provided here does not apply to your case, or if it seems outdated, we highly recommend checking the related known issues, verifying the version of the permanent fix, and confirming that you have installed the latest versions of themes and plugins. Should you need further assistance, please do not hesitate to open a new support ticket. For further assistance, you can reach out to us on the WPML support forum.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Prosenjit Barman 1 month, 3 weeks ago.

Assisted by: Prosenjit Barman.

Author Posts
February 16, 2024 at 7:17 am #15310158

Caetano

All links are being translated except the one in the section.
This is the first time I tried to use a link in the all section.
I am using Divi theme, and the link of the section is not being translated nor i can find it anywhere to do it manualy.

Thank you,
Marcos

text-ok.jpg
section-not-ok.jpg
February 16, 2024 at 8:09 pm #15313084

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi there,

While waiting for one of my colleagues to help you, please access the translation editor(I assume you are using the Advanced Translation Editor) and at the top left use the search bar.

In the search bar add either the whole URL or part of it and you should be able to now locate it for translation.

Let us know your results, please.

Documentation:
https://wpml.org/faq/how-to-translate-urls-shortcodes-and-html-attributes-using-the-advanced-translation-editor/

February 16, 2024 at 8:44 pm #15313107

Caetano

It does not work.
The section link somehow is not listed. Even if i try to find it.
For the moment I added a button instead.

Xnip2024-02-16_20-39-05.jpg
February 19, 2024 at 11:18 am #15317603

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hello Marcos,
I hope you're doing well. I've taken over this ticket and will be happy to assist you further in this matter.

If the page that you're linking in the 'Section Link URL' field has been translated, the link should automatically update to reflect the corresponding version in other languages. If the page is translated and the link is still not updating automatically, please do the following and check if that helps in solving the issue.

- Please go to "WPML > Settings" and scroll down to the 'Translate Link Targets' section.
- Click on the "Scan now and Adjust links" button and wait till the process is completed.

Most of the time, that option helps to solve the issue of incorrect links on the translations. Please give it a try and let me know how it goes. I will be happy to help if you need further assistance in this matter.

Best regards,
Prosenjit

February 21, 2024 at 1:13 pm #15328158

Caetano

Helo Prosenjit,

Nothing I tried solved that issue. I had to make a workarround with a button.
I thing links on entire sections are not being translated in Divi theme. But only if its a Section Link.

Thank you anyway,

Marcos

February 22, 2024 at 6:07 am #15331099

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hello Marcos,
Thank you for giving the suggestion a try!

To determine whether the problem is specific to your site or is a broader issue, I would appreciate it if you could try to replicate the issue on our sandbox site. The Autologin link to our sandbox is given below.

- hidden link

The WPML and its add-ons are already installed there. Just complete their setup. Once done,. install the Divi theme and other plugins that will be required to reproduce the issue.

If you successfully replicate the issue in our sandbox, please let me know. I will review the situation and advise you on the next steps. If necessary, I will also escalate the matter to our development team for a more in-depth analysis.

Please feel free to let me know if you need assistance with configuring anything in the sandbox. I'll be happy to help.

Looking forward to your response and I appreciate your kind cooperation in this matter.

Best regards,
Prosenjit

February 22, 2024 at 11:41 am #15333233

Caetano

Ok, thank you,

You can test it out!
The button link works, the Section link doesn't.

Best regards,
Marcos

February 23, 2024 at 5:10 am #15336022

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hi Marcos,
Thank you so much for recreating the issue in the Sandbox.

I've conducted tests and successfully identified the underlying problem. The Translation support for the Link field hasn't been implemented yet, which is why the link isn't displayed in the Translation editor for translation, nor does it update automatically. To address this, I added the following code into the "WPML > Settings > Custom XML Configuration" to enable translation registration for the link field, which effectively resolved the issue.

<wpml-config>
  <shortcodes>
    <shortcode>
      <tag>et_pb_section</tag>
      <attributes>
        <attribute>link_option_url</attribute>
      </attributes>
    </shortcode>
  </shortcodes>
</wpml-config>

If you notice any Divi module not displaying translated content in other languages, you can refer to the following guides and ensure that the module is registered for translation.

- https://wpml.org/documentation/theme-compatibility/divi-builder/#adding-support-for-more-divi-builder-modules
- https://wpml.org/documentation/translating-your-contents/page-builders/how-to-register-page-builder-modules-and-theme-options/

Let me know if that helps or if you need further assistance in this matter. I will be happy to help.

Best regards,
Prosenjit

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.