Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 2 years, 3 months ago.

Assigned support staff: Itamar.

Author Posts
April 12, 2018 at 7:41 am #1604770

guidoL-5

I am trying to: Delete posts that do not have any language information

Link to a page where the issue can be seen: I can only share the link in private.

I expected to see: Only valid posts

Instead, I got: 404 to posts that I cannot see in the backend.

April 12, 2018 at 3:38 pm #1611449

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thank you for contacting the WPML support forum.

If I understand you correctly, you have links on the frontend of your site that are getting to a 404 page because you have deleted those posts on the backend.
Is this correct?
If so then it is expected, and you should also delete those links from your site.
If I've misunderstood you, then please elaborate on the issue.
I have the URL of your site so to see the issue on your site you can simply add here the last part of the URL. And also add some screenshots that show me the problematic links.
You can make use of “upload an image” below the comment area to upload screenshots.

Thanks,
Itamar.

April 13, 2018 at 1:50 am #1616363

guidoL-5

Hello Itamar,

No, I have a sitemap which has posts that link me to 404 links. I cant see them on the backend too. But when I access them directly through the ID I can see them. So most probably they were not linked correctly or something.

I need a way to bulk delete these since they are quite a lot. The link I have is different from what you have.

April 15, 2018 at 6:30 pm #1637919

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

So please share with me the access to your site and explain to me how to see and understand the problem on your site.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved, I will delete the local site. Let me know if this is ok with you.
** IMPORTANT **
- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields, this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Thanks,
Itamar.

April 23, 2018 at 10:22 pm #1777646

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks for the access details.

Please tell me if the following is correct.
Is this one of the posts that you get 404?
/research/music-of-the-previous-generations-is-hot-again-this-year/

April 24, 2018 at 10:09 am #1785800

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi again.

We have another ticket in the Italian forum with a case that seems to be somewhat similar to the case on your site. I'm trying to figure out if it is the same case. You can see it here (Italian language). https://wpml.org/it/forums/topic/yoast-seo-sitemaps/.
Anyway, it is an issue that we can replicate on a clean WordPress installation. And this issue is now escalated to our second tier supporters. The issue is happening when the Language URL format is set to "Different languages in directories," and the "Use directory for default language" and the "A page" options are also selected. This is the way your site is configured. When it is set like this the sitemap at yoursite.com/sitemap_index.xml will be 404, and instead, it will be in yoursite.com/nl/sitemap_index.xml. But the links in it will be wrong like this yoursite.com/post-sitemap.xml (without the /nl/) which will also lead to 404.

Currently, I'm not sure that that is exactly the case on your site. But your site is a multisite and also the Yoast SEO plugin on your site is not updated to its latest version if I'm not mistaken.

So further elaboration on your part can help me understand the issue. If you do not want to reveal info from your site, I'm enabling private message for the next reply where you can add links and screenshots that explain the issue.

Thanks,
Itamar.

The topic ‘[Closed] Seeing 404 links to unlinked posts’ is closed to new replies.