This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Yvette 2 months, 3 weeks ago.

Assigned support staff: Yvette.

Author Posts
June 17, 2019 at 1:53 pm #4035901

stefanP-20

I am trying to:

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:
this was your last suggestion, we tried everything but nothing helps.

Hi,

Could you please try below steps and let me know how it goes?

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

1
2
3
/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );
2. Please re-save permalink by pressing ‘Save Changes’ button from Settings >> Permalinks and see if this resolve your issue:
https://codex.wordpress.org/Settings_Permalinks_Screen

3. I have noticed that you are using an older version ( 3.22.6 ) of ‘DIVI’ theme and latest version of ‘DIVI’ theme is 3.24, please update the theme and see if this resolves your issue.
hidden link

4. Could you please clear all sorts of caches in your site plugin cache / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards.

5. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

June 18, 2019 at 4:59 am #4040261

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Clarifications

1.1 Previous ticket
Is this the previous ticket that you were working on?
https://wpml.org/forums/topic/switching-between-languages/

If so, the status of the ticket is "waiting for response". You are not able to post a response on this thread still?

1.2 Do you wish to continue here or on the previous ticket?
If you wish to continue here - then please close the other ticket on the forum as we cannot have 2 tickets open on same topic.

2. Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

June 18, 2019 at 7:46 pm #4046295

stefanP-20

correcting:

Lilleland2013 is the username

June 19, 2019 at 9:48 am #4050411

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

As a test, I activated the WPML standard "Footer" language switcher.

This switcher is working they way it should while the "menu" switchers are not.
Could you please upgrade your DIVI theme to the latest release?

Then please confirm if the problem is still existing. Please also confirm that you can see that the footer switcher i s working as it should.

Thanks

June 19, 2019 at 4:35 pm #4053435

stefanP-20

hello,

it is the same with booth, the switchers only work when you are the "starting-page" of the website. once you are in the menu or submenu no one works.

I got a strange e-mail from WordPress today about something wrong on my site.:

Hej!

Från och med WordPress 5.2 finns det en inbyggd funktion som kan upptäcka när något tillägg eller tema orsakar ett allvarligt fel på din webbplats och informerar dig via detta e-postmeddelande som skickas automatiskt.

I detta fall har WordPress upptäckt ett fel med ett av dina tillägg, WPML Multilingual CMS.

Börja med att besöka din webbplats (hidden link) och kontrollera om du märker några synliga problem. Därefter går du till sidan där problemet inträffade (hidden link) för att kontrollera om du ser något där.

Kontakta ditt webbhotell för att be om mer hjälp med detta problem.

Om det skulle se ut som om webbplatsen inte fungerar och du inte kommer åt adminpanelen som du borde, har WordPress nu ett speciellt ”räddningsläge”. Det låter dig på ett säkert sätt logga in i adminpanelen för att undersöka problemet vidare.

hidden link

För att inte äventyra säkerheten på din webbplats kommer denna länk att gälla endast 1 dag. Oroa dig inte över detta. Om felet skulle inträffa igen efter det kommer du att få ett nytt e-postmeddelande med en ny länk.

Uppgifter om felet
==================
Ett fel av typen E_ERROR uppstod på rad 143 i följande fil: /web/com/www.gottskarhotell.com/wp-content/plugins/sitepress-multilingual-cms/menu/post-menus/post-edit-screen/wpml-meta-boxes-post-edit-html.class.php. Felorsak: Uncaught Error: Cannot use object of type WP_Error as array in /web/com/www.gottskarhotell.com/wp-content/plugins/sitepress-multilingual-cms/menu/post-menus/post-edit-screen/wpml-meta-boxes-post-edit-html.class.php:143
Stack trace:
#0 /web/com/www.gottskarhotell.com/wp-content/plugins/sitepress-multilingual-cms/menu/post-menus/post-edit-screen/wpml-meta-boxes-post-edit-html.class.php(57): WPML_Meta_Boxes_Post_Edit_HTML->translation_priority()
#1 /web/com/www.gottskarhotell.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1976): WPML_Meta_Boxes_Post_Edit_HTML->render_languages(Object(WP_Post))
#2 /web/com/www.gottskarhotell.com/wp-admin/includes/template.php(1304): SitePress->meta_box(Object(WP_Post), Array)
#3 /web/com/www.gottskarhotell.com/wp-admin/edit-form-advanced.php(635): do_meta_boxes(Object(WP_Screen), 'side', Object(WP_Post))
#4 /web/com/www.gottskarhotell.com/wp-admin/post.php(197): include('/web/com/www.go...')
#5 {main}
thrown

June 20, 2019 at 7:53 am #4057349

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Switchers
On this page: hidden link

The menu switchers you have added, I agree, are NOT working. However, the standard WPML footer switcher **is** (see images)

I believe that this is because you have included the menu in the module "Full width menu" and this may not be supported by WPML at the moment.

To be certain this is the case, could you please upload the latest Divi theme here:
hidden link

This sandbox site has been loaded with the latest WPML plugins. Please install your theme, create a layout with the Divi builder as in your site and then incorporate it into the header.

If you are able to re-create the issue, I can then send it to our compatibility team for resolution.

2. New Ticket
Please open a new ticket for this issue as it is unrelated to the current one we are working on. When you open the ticket, please indicate what action you were doing when you received the notice.

Thanks

June 23, 2019 at 7:04 pm #4073513

stefanP-20

hello,

Sorry, don´t getvit. I have not what I know done anything in the menu-builder. I just filled out the options in the WPML - menu.....

I do not understand what I am supposed to do... I am sorry

June 25, 2019 at 7:31 am #4081789

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

1. Log into this site: hidden link
2. Upload your version of the DIVI theme
3. Create a menu and translate it
4. Create a header layout that includes the module "Full width menu" and incorporate your menu(s) in it.
5. Translate the header layout
6. Create sample page and translate it
7. Confirm that the same problem happens on this site as you have on yours.
8. Write back with the results

In short: I believe that WPML does not support the DIVI module "Full width menu".

July 6, 2019 at 1:36 pm #4155949

stefanP-20

Hello Yvette,

I contacted my more experienced web-lady. Before she do all this work she wonders why the flags work on the main-page then? that is the same module, "full width menu" as the not working pages!!

rgds Stefan

July 8, 2019 at 7:45 am #4159599

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

It could be because the language switcher on the "home" page will use the values taken from the database fields "home" and "siteurl" as the permalink base to create the language versions. On normal pages, the permalinks are only used for rewriting.

However, this is why we are replicating the problem on a clean site and escalating it to our compatibility team for investigating.

I see that you have not used the site that I provided so I will have to create a new one since the old one expired. Before I take the time to do this, please indicate if you are now willing to cooperate on this matter or, alternatively, you can have your more experienced web-lady figure out the compatibility issue and report it to our team.

Kind regards

July 8, 2019 at 8:29 pm #4165603

stefanP-20

hello,

she is as confused as everyone!!

I will send her your reply and check what she thinks....... starting to get really annoying now I think

July 9, 2019 at 7:14 am #4167931

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Yes, I agree.

If you simply execute the steps I asked for on the sandbox site, I feel we could resolve this ticket faster. it should take you no more than 5' to load the theme, create a simple page and the header template using the menu shortcode. I can then escalate directly to our compatibilty team. This is the recommended course of action in my opinion.

Here is a new site for you again. It is only valid for 7 days.
hidden link

July 21, 2019 at 8:58 pm #4252999

stefanP-20

We now moved the menu to the top, but the menu does not sync on the english version!!!!

there are now 2 menues on the english version

July 22, 2019 at 11:54 am #4256847

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I just visited your site in EN and I do not see 2 english menus.

If you have now changed your approach and no longer plan to use the "Full width menu" shortcode, please close this ticket and open a new one with a full description of what the current problem is.

This ticket has become a bit convoluted and confusing to follow.

July 22, 2019 at 4:20 pm #4259859

stefanP-20

hi again,

Elegant Themes solved that problem !!!! but one other problem is the page "RUM" under HOTELLET , this page does not show in english version!!!

stefan