Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to select translated footer templates in OceanWP theme options?

Solution: 1) Go to WPML->String Translation

2) Go to Bottom of the page and click on Translate texts in admin screens »

3) Search for "theme_mods_oceanwp-child-theme-master" and check the "ocean_footer_widgets_template" and click on apply.

4) Wait until the following message appears after clicking Apply.

5) Now go to string translation you will see an entry with ocean_footer_widgets_template and you get a library id, on its translation you should enter the translated library id.

50% of people find this useful.

This topic contains 6 replies, has 2 voices.

Last updated by Rainer 1 year, 4 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 20, 2018 at 5:41 am #2536289

Rainer

Hi,

I´m using a child theme of oceanwp with elementor. I´ve created a translation of an elmentor template, which is used as footer. At OceanWP theme options I´ve set the footer elementor template as template for the footer. When I switch the language now, the footer stays in the same language while the page translation is working. The same problem occurs on the header template.

The oceanwp support told me, that you´ve solved such a problem a time ago: "Hello, I see that you use a child theme, the way is a little different, can you ask to the WPML support because another user had the same problem with a child theme and they tell him how to do."

This was my original query:
Hi,

I´ve read your documentation about the custom templates (Theme Panel => My Library), which I used with elementor. I´ve assigned these templates at the customizer for header and footer.

I created a new translation for the footer template (hidden link) and changed a text widget to see if this translation is working on the english home page. It seems that the english home page has the same footer template like the german one.
hidden link
hidden link

How can I assign the english template at the customizer? Is this a bug? Have I done it wrong? As I´ve to edit links and image I cannot use the wpml translation editor for strings.

Thanks and regards,

Would be great, if you can help!

July 23, 2018 at 4:11 am #2568648

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Are you using Elementor Global Templates, we have some issues with Global Templates, so could you please view the errata page and see if this helps? https://wpml.org/errata/elementor-global-templates-translation-are-not-working/

Look forward to your reply.

Thanks

July 23, 2018 at 6:00 am #2568691

Rainer

Hi,

I use the global templates at oceanwp, not at elementor. Translating the templates is not a problem as I can duplicate the templates, translate it and assign it to the different languages.

But how can I ensure that the translation is used at oceanwp theme options? That is the main problem. I need a very quick fix!

Regards,

July 23, 2018 at 12:31 pm #2569692

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Let me check how the templates are assigned so I can provide a feedback for this.

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

July 24, 2018 at 9:36 am #2572991

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Please follow the below steps to fix the issue:

1) Go to WPML->String Translation

2) Go to Bottom of the page and click on Translate texts in admin screens »

3) Search for "theme_mods_oceanwp-child-theme-master" and check the "ocean_footer_widgets_template" and click on apply.

4) Wait until the following message appears after clicking Apply.

5) Now go to string translation you will see an entry with ocean_footer_widgets_template and you get a library id, on its translation you should enter the translated library id.

Let me know if this helps.

Thanks

July 24, 2018 at 11:20 am #2573556

Rainer

Hi,

thanks, can you please add the missing code snippets / pictures in your reply as you tell?

Regards,

July 24, 2018 at 11:26 am #2573582

Rainer

Hi,

I could figure it out by myself. Perhaps you can write down this for your faq 🙂

Thanks and regards,