No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 27 replies, has 3 voices.

Last updated by Alejandro 6 months, 1 week ago.

Assigned support staff: Alejandro.

Author Posts
January 10, 2019 at 4:21 pm #3077061

Ricardo Prins

My website is translated via WPML into English, German and Dutch. But all translated pages are automatically assigned as 'duplicates' and for that reason are not at all indexed by google. How do I fix this?

Since it is very important to me that all products and pages (German, Dutch and English) are indexed in google. I attached a screenshot of the error messages I get for almost ALL of my translated pages (185 pages are not indexed atm)

Thanks in advance.

Ricardo Prins

January 10, 2019 at 5:17 pm #3077276

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

Could you please check out this guide and let me know if it's helpful to your situation, please?

https://wpml.org/documentation/support/multilingual-seo/

Also read this one and let me know if it applies to you (i think it is):
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/#what-about-seo

There we explain how it works and give a few tips on how to make sure google doesn't do what's going on with you.

If There's something more to it, could you point me to one of the pages that are being flagged as duplicate content, so i can check it out and test for problems?

Thanks in advance.

January 10, 2019 at 5:24 pm #3077302

Ricardo Prins

Hello!

So for example, this page: hidden link

Thanks in advance.

January 11, 2019 at 9:20 am #3079837

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Could you please tell me the steps you took to create this product? you talk about duplicating the product but i see it translated, and as you said, they are not duplicates.

You say "But all translated pages are automatically assigned as 'duplicates'", can you tell me what exactly do you mean by this? who is assigning the products as duplicates? Google or WPML?

Thanks in advance for the explanation.

January 11, 2019 at 9:36 am #3079883

Ricardo Prins

I did indeed not duplicate them, but I translated the products via the regular way. Though, google reads those translated pages as 'duplicate' while it's not the case. That's the issue here. So google assigns the translated pages to be duplicates while they are non-duplicate translations with unique texts etc. So is there some settings within WPML that does this and how can I stop this from happening and let google read the translated pages as non-duplicate and have the properly indexed.

Thanks in advance.

January 11, 2019 at 12:51 pm #3080726

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Could you please confirm you have the most recent version of WooCommerce and our Plugins?

Just to make sure, you need to have the following plugins installed: WPML, WooCommerce multilingual, String Translation and Translation Management and have them correctly updated and installed (and please tell me the versions installed).

Thanks in advanced.

January 11, 2019 at 2:47 pm #3081149

Ricardo Prins

Thanks for replying in Italian. I wish I'd spoke that haha!

For now, would you be so kind to translate to English?

Thanks 🙂

January 11, 2019 at 6:18 pm #3081688

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sorry about that, i translated everything into English now.

I'm inviting your developer and once he/she joins i'll have the ability to ask for credentials or other options (safely) because what you are experiencing is rather strange and it's definitely not normal, so we need to further investigate the issue (at a deeper level).

January 16, 2019 at 11:15 am #3097281

Ricardo Prins

Are you inviting our developer? Or I should do it? How do I invite someone in this conversation?

Thanks

January 16, 2019 at 11:23 am #3097293

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I already did, our system let us send him an automatic mail, that will allow us to enable a few provate fields that we need(Credentials, etc).

You can just contact him/her and let him/her know tha we sent them a mail with the invitation. as soon as he/she joins we will be able to ask for credentials or any other private information and enable the proper fields for them.

Please contact him/her if you can so we can resume with the troubleshooting procedure.

January 18, 2019 at 9:54 am #3105362

Ricardo Prins

Who exactly did you send an email? We have multiple developers working on the site sometimes.

Thanks.

January 18, 2019 at 2:11 pm #3106286

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

In our system it says "Petra", She/he was invited the day we first replied this ticket.

Regards.

January 21, 2019 at 10:54 am #3111955

Petra

Hi Alejandro, we joined this conversation. Which info do you need to continue the support for this issue?

Kind Regards, Roxan

January 21, 2019 at 5:10 pm #3113407

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!

Thanks for joining, now i can ask for the private access (Credentials and debug info) needed for me to proper debug this issue!

I enabled boh fields, one for the debug information and another one for access to the site, so i can take a closer look at what's going on.

Please provide me this information so i can go check what is happening.

- If you don't know where to get the debug info from, you can follow this guide: http://wpml.org/faq/provide-debug-information-faster-support/

The same goes for the private access, you can add it in the field i just activated.

Please know that the private fields might only appear to the developers so it's better if the developer adds the credentials to avoid them being public.

Thanks in advance!

January 23, 2019 at 8:48 am #3119409

Petra

Hi Aejandro,

I think something went wrong, the 'private' fields disappeared. Did you recieved them or should I aply them again?