This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Yaniv 5 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 16, 2019 at 6:47 am

Yaniv

Hi,

I'm having very critical performance issues on my Woocommerce website.
The two main culprits are the WPML plugin bundle and WooCommerce Dynamic Pricing & Discounts plugin. Each adds an average of 5-7 seconds of loading time.

I tested both scenarios:
- Disabling the WPML bundle and testing Dynamic Pricing & Discounts on its own
- Disabling Dynamic Pricing & Discounts and testing WPML on its own

Both scenarios load shop and category archives at around 13-15 seconds. Disabling both WPML and Dynamic Pricing & Discounts loads the same pages at around 5 seconds. The performance also affects the admin area, but this is minor compared to the frontend.

I've setup a staging site for you to test this out (credentials in the private area below). The performance issues in the staging site are identical to the ones in the production site. Please help me find a solution as soon as possible - the sales on the website are taking a serious hit because of these performance issues. I've also contacted WooCommerce Dynamic Pricing & Discounts to help me out with the performance issues of their plugins.

Thanks,
Yaniv

May 16, 2019 at 7:37 am #3822687

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

Please go to WPML > languages > Make themes work multilingual, Disable the option => Adjust IDs for multilingual functionality.

This should have some performance improvement. I have disabled it on the staging site and the shop seems to load in 6 seconds. please check the attached screenshot.

I hope this helps you better, Let me know the results

Kind regards
Raja

May 16, 2019 at 9:01 am #3823415

Yaniv

Hi Raja,

Thanks for your quick response. I do not see any difference in loading time on the staging site.
I disabled the option on the production site, and likewise - there is no difference in loading time for the category archive pages.

What else can be done?

Thanks,
Yaniv

May 16, 2019 at 2:22 pm #3826869

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Yaniv,

I can see a huge difference in loading time between the staging and production site.

For eg: hidden link loads in 4.66 s
and the same page in production site is taking around 12.66 s

Maybe a snapshot copy of your production site would help us identify the issue, You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

I have enabled the private response for you to securely share the package.

Kind regards
Raja

May 16, 2019 at 5:23 pm
May 17, 2019 at 6:12 am #3831517

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

That's quite huge, I have started the download i think it might take some while to finish. I will update you once I have the duplicator setup.

Kind regards
Raja

May 17, 2019 at 12:33 pm #3834413

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Yaniv,

Please update to the latest version of WPML and the related plugin it should improve the performance If you are still experiencing slowness please follows the steps in the documentation https://wpml.org/faq/prevent-performance-issues-with-wpml/

I hope this helps you better, Let me know the results.

Kind regards
Raja

May 25, 2019 at 5:22 am #3888819

Yaniv

Updating all the plugins did improve the performance a bit.
Thanks!