This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 3 voices.

Last updated by Bigul 1 month, 1 week ago.

Assigned support staff: Bigul.

Author Posts
August 20, 2019 at 6:15 pm #4425961

essamH

Dear Team,
I wish you could reply quickly because our production site is dying due to a high usage on the memory and CPU is 0%

I did all the trouble shooting mentioned in other threads.

Issue started by a few DB errors like this one

Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_options ( `option_name`, `option_value`, `autoload` ) VALUES ('wpml.WPML_ST_DB_Cache.lock', '1566320359', 'no') /* LOCK */ made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, wp_widgets_init, do_action('widgets_init'), WP_Hook->do_action, WP_Hook->apply_filters, YITH_WCAN->registerWidgets, register_widget, WP_Widget_Factory->register, YITH_WCAN_Navigation_Widget->__construct, __, translate, apply_filters('gettext'), WP_Hook->apply_filters, icl_sw_filters_gettext, icl_translate, WPML_Register_String_Filter->translate_by_name_and_context, WPML_Displayed_String_Filter->get_translation, WPML_ST_DB_Cache->get_translation, WPML_ST_DB_Translation_Retrieve->get_translation, WPML_ST_DB_Translation_Retrieve->load, WPMLUtilitiesLock->create

and

Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_options ( `option_name`, `option_value`, `autoload` ) VALUES ('wpml.WPML_ST_DB_Cache.lock', '1566232892', 'no') /* LOCK */ made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, ActionScheduler_wpPostStore->init, ActionScheduler_wpPostStore_PostTypeRegistrar->register, ActionScheduler_wpPostStore_PostTypeRegistrar->post_type_args, __, translate, apply_filters('gettext'), WP_Hook->apply_filters, icl_sw_filters_gettext, icl_translate, WPML_Register_String_Filter->translate_by_name_and_context, WPML_Displayed_String_Filter->get_translation, WPML_ST_DB_Cache->get_translation, WPML_ST_DB_Translation_Retrieve->get_translation, WPML_ST_DB_Translation_Retrieve->load, WPMLUtilitiesLock->create

Everything was fine i thought it is normal errors and nothing more, everything was working just fine for 2 days

and suddenly the cpu usage is 100% and website became very slow it is still working and i guess the reason is that am hosting the website on AWS Large plan from Cloudways.

Other trouble shooting

I cloned the entire server when i check the new server issue was gone
I cloned the server again on a digital ocean server also there were no issue on the cloned server

I have no idea what to do am ready to give you access incase if you need.

Hope you reply very soon

August 21, 2019 at 9:29 am #4429411

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

We recently released a beta version of the plugin with performance improvements so can you try this on a staging server and let me know if this helps? https://wpml.org/2019/08/wpml-4-3-beta-1-with-much-faster-string-translation/

Further, can you please review the following articles and see if all the relevant steps are covered?
https://wpml.org/faq/prevent-performance-issues-with-wpml/
https://wpml.org/2012/01/can-your-site-run-faster/

Also, try disabling and re-enabling all WPML plugins and then going to WPML > Support > Troubleshooting and press the "Recreate ST cache tables" button.

The first visit after the re-activation of the plugins is kinda slow, but after the regeneration of the tables - it will be better.

Look forward to your reply.

Thanks

August 22, 2019 at 4:51 pm #4441663

essamH

Dear,

Allow me some time this is punch in the face full of information i have to read each guide and give you my feed back ASAP

Also i will test the wpml Beta version to see if it going to improve the performance or not.

Thanks in advance

August 23, 2019 at 10:40 am #4445923

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sure, no problem. Take your time to test things.

Thanks

August 26, 2019 at 10:59 am #4457855

essamH

To keep you updated.

I have 1600 Variable products

What i did i changed the AWS hosting to Digital ocean hosting with more resources 48GB Ram and 12 Cores, so far the performance issue is not a problem any more.

The Deadlock issue still remains
I did not install the new beta wpml version what is your advise for the deadlock errors?

August 27, 2019 at 7:38 am #4463401

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am Bigul from WPML support team. Shekhar is on vacation now. So I am taking care of this ticket. Hope it will be okay for you.

Thank you for the updates. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Deactivate WPML plugins

2) Activate WPML plugins again

3) Go to WPML>>Support page

4) Click on Troubleshooting link (blue link in the middle of the page)

5) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

September 1, 2019 at 7:58 am #4492195

essamH

Sure,

I will do all the above steps today and i will keep you updated.

So far the error still appears on a regular basis, although the website is working fine but it scares me to see this kind of errors.

September 2, 2019 at 7:58 am #4495121

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Take your time and let us know. We will wait for your feedback.

--
Thanks!

Bigul

September 3, 2019 at 8:39 am #4502085

essamH

Above steps are done.

I will post any errors appears in this thread.

September 4, 2019 at 7:19 am #4508731

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please check and share it with us. We will wait for your feedback.

--
Thanks!

Bigul

September 4, 2019 at 5:31 pm #4513163

essamH

So far, there is no DB errors. i will wait for another 24 hours then i will update you or i will close the ticket thanks for your patience

September 9, 2019 at 12:43 pm #4537181

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Hope the issue is resolved now.

--
Thanks!

Bigul

September 11, 2019 at 8:54 am #4551837

essamH

Hi,

Issue still not resolved and errors are back.

Is it safe to post the error log records here it contains the urls of the website ?

September 11, 2019 at 10:04 am #4552387

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. We have released a new version of WPML(4.2.8) recently. Please upgrade to the latest version after a full site backup and make sure the issues are existing or not.

If the issue exists, please paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

The topic ‘[Closed] Server high load CPU is 100% used while wpml is active’ is closed to new replies.