Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bobby 4 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
March 22, 2022 at 9:56 am #10845119

zolM

Hi, I recently checked my server's log and I see this error coming from WPML, please let me know what this error means for my website and what can I do to fix this?

Thank you
Zol

wpml.jpeg
March 23, 2022 at 6:03 am #10853513

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I would need to see the detail of the error. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . 'https://cdn.wpml.org/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

March 24, 2022 at 10:53 am #10866415

zolM

Hello there,

You can find the information here: hidden link
Please let me know what else can I be doing to solve this. Thank you

Best,
Zol

March 24, 2022 at 4:28 pm #10870069

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for sharing the error log

Please go to your database table icl_string_packages and review the structure.

Verify with me if the AUTO INCREMENT key is there.

See my screenshot for an example of what to look for.

Screen Shot 2022-03-24 at 9.27.20 AM.png
March 25, 2022 at 7:55 am #10874073

zolM

Hi, I don't see the same as the screenshot you provided me with. Please have a look at my tables, I don't see anything else.

WhatsApp Image 2022-03-24 at 22.55.54.jpeg
March 25, 2022 at 9:49 pm #10880131

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I would like to request temporary access (wp-admin and FTP) to your site to test the issue.
(preferably to a test site where the problem has been replicated if possible)

**Before we proceed It is necessary to take FULL BACKUP of your database and your website. Providing us with access, you agree that a backup has been taken **

I often use the Duplicator plugin for this purpose: http://wordpress.org/plugins/duplicator/
You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you enter is private which means only you and I have access to it.

NOTE: If access to the live site is not possible and the staging site does not exist please provide me with a duplicator package created with the duplicator plugin.

Thank you,
Bobby

March 28, 2022 at 7:24 pm #10896749

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details!

The screenshot you shared with me was from the table contents, we needed to review the 'structure' which was indeed missing the AUTO INCREMENT key causing this behavior.

I have now fixed it and it should be working as expected

Let me know your results, please.

March 29, 2022 at 9:52 am #10900537

zolM

Hi,
so it was fixed in the staging site or the life site please let me know.

Thank you,
Zol

March 29, 2022 at 7:36 pm #10905871

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

It was fixed in the site I had access to which was hidden link

You can review the database table to confirm that now AUTO INCREMENT is indeed enabled

April 5, 2022 at 8:47 pm #10957913
zolM

Hi. Bobby, Thanks for your answer. I will be checking this. In the middle while, could you please help me out with this?

I'm trying to connect the original and the translated articles, but it does not allow me to do so. When I click on it, nothing happens. could you please let me know how to fix this? Thank you.

New threads created by Bobby and linked to this one are listed below:

https://wpml.org/forums/topic/split-servers-log-wpml/

Screen Shot 2022-04-05 at 10.30.01 PM.png
April 5, 2022 at 10:55 pm #10958317

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi there,

If possible, please mark this ticket as resolved.

We try to keep each ticket to a minimum of one issue.

Please refer to the link above for the new split ticket regarding the translation connection issue.