Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 10 replies, has 3 voices.

Last updated by kostantinosK 1 year, 10 months ago.

Assigned support staff: Bobby.

Author Posts
September 25, 2018 at 10:36 am


I am trying to:Complete an order to a secondary language in my website

Link to a page where the issue can be seen: hidden link

I expected to see: I expected to complete the order at the checkout.

Instead, I got: Session expired

Hello, I am having a huge problem on my website at the moment. Every non logged customer that goes to the checkout receives a session expired message and removes the products from the cart. The problem is solved once I disable WPML. The problem also happens if I only have WooCommerce and WPML active so it is not a secondary plugin compatibility problem.

September 26, 2018 at 3:06 pm #2767783

Ricardo Alday


Thank you for contacting WPML support.
When I logged into our WP dashboard I noticed that there's an error message regarding WP-Rocket not being able to write to the .htaccess file.
That same problem might be affecting your checkout page.

WP-Rocket has a document with a few pointers to fix that issue: hidden link

Also, please contact your hosting provider to activate mod-rewrite.
Learn more here:
hidden link

We have several customers on WP Engine with this specific issue. It's solved when WPEngine supports enables mod-rewrite on their sites. You might be running into the same problem.

Let me know if that helps.

Best regards,

October 1, 2018 at 7:00 am #2777209


Dear Ricardo,

We made htaccess writable but we are still experiencing the same error. Mod-rewrite was already enabled.

October 1, 2018 at 9:37 am #2777590


Update: we completely deactivated WP rocket and as I referred to on my original post, it does not solve the problem. As I told you, the problem persists even after disabling everything except woo and wpml.

October 1, 2018 at 5:46 pm #2779048

Ricardo Alday

I just tested the checkout page on your site.
The problem does not occur anymore, either logged in or out.

Can you clear your browser cache and cookies and try again?

October 2, 2018 at 5:35 am #2780353


I can confirm that it is still happening for me. Cleared my browsers cookies and cache, tried from my computer and cell phone and co worker's cell phone.

This problem is bleeding us and creates a bad reputation for our customers. Unless you start acknowledging that it might be your plugin to blame so we can take the next steps on finding a solution we cannot progress. As I told you earlier, the website with every plugin disabled but woocommerce and wpml, is still having the same problem.

October 2, 2018 at 6:05 pm #2782444

Ricardo Alday

I understand your concern that's why I had some of my colleagues check the page as well. None of us could replicate the problem.
I'm attaching a screenshot from one of teammates who also was able to add items to the cart and proceed to the checkout page.

This morning, I noticed that that the checkout link you posted originally: hidden link now redirects to hidden link however, I still don't see the issue. I recorded a screencast to show you: hidden link

As yo can see, the /checkout/ page shows the item and total, the /cart/ page shows the same information but in a different layout.

October 3, 2018 at 8:05 am #2783844


Dear Ricardo,

The behavior of the error is really erratic. It does not always trigger, it does though pretty frequently. As you can see on the video below, the session expired error triggers on the 3rd try. Also upon the session expired message, if I refresh my page I get an item no longer available message (despite it being available). You can also see in my video that I clear all cookies and cached files. Also the cache plugin on the site is deactivated (although, as described in my OP it is not it causing the problem).

Please see the video here: hidden link

Waiting for your response. Thank you.

October 4, 2018 at 5:45 am #2786446


Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)


Ricardo is currently offline.

i was able to replicate the issue on my first visit to your site , but on the 4 next tries it worked as expected.

if possible please provide me with your error log as i am hoping there has been some sort of an error logged. I have inspected your console and even though there are errors they do not seem related to this.

You can see how to enable debug logging here:

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

October 4, 2018 at 6:02 am #2786476


Hello, bellow I attach you the debug.log

hidden link

October 4, 2018 at 7:37 pm #2788684


Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)


There some warnings and notices stemming from wordpress country selector and yith woocommerce plugins but warnings and notices are usually not alarming and would be unlikely that they would cause this issue.

I understand you have mentioned that you dont believe that this is related to a secondary plugin , but i have test this locally with the latest versions of WPML + Woocommerce + Woocommerce Mutlilingual and i have not been able to replicate the issue.

have you been able to test this on a clean enviroment with just the WPML plugins Woocomerce and Woocommerce Mutlilingual enabled ?

this should be done in a local environment or a staging/dev site.

if you do not have a staging/dev site available , please provide me with access to try and create one to test locally.

October 5, 2018 at 9:53 am