This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.32 hours from now. Thank you for your understanding.

This topic contains 8 replies, has 2 voices.

Last updated by Noman 3 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
July 1, 2019 at 6:43 am #4115877

Andre Koebel und

Everytime when i want to set a custom field on the post edit screen as "translate" it switched back after saving the post to "Not translate". Why?

July 1, 2019 at 8:11 am #4116429

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support. Could you please follow below steps and let me know how it goes?

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

If still issue persists, please enable error reporting at you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

After adding the above code please try to reproduce the issue and this will create debug.log file in your site's wp-content directory. Please send me its contents.

Thank you

July 1, 2019 at 12:44 pm #4118993

Andre Koebel und

Hey Noman,

the Memory Limit is not the problem. And there are still no errors in the debug.log.

The problem still exists without any other plugin or with the default themes.

July 2, 2019 at 8:06 am #4124887

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

July 2, 2019 at 3:41 pm #4128491

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have tried to open wp-admin page of your site and it asking me to enter username/password to see login page. Could you please provide me username/password so that I can debug this issue.

Thank you

July 3, 2019 at 3:09 pm #4137759

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have tried to open wp-admin page in Chrome/Firefox with and without proxy but it’s not opening here as you can see in the attached screenshot. If you have some security plugin installed then please deactivate it, otherwise I’ll create a test server for you in Cloudways to debug this issue.

Thank you

July 4, 2019 at 4:26 am #4140319

Andre Koebel und

No we have no security plugins or something else. Where u access from? We used the german hoster "allinkl", i dont know if there block some ip ranges. The page is working correctly for me. :/

Ok then please cloudways...

July 8, 2019 at 3:23 am #4158809

Andre Koebel und

The migration is done. 🙂

July 9, 2019 at 8:15 am #4168411

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for Moving your site to cloud server. In order to reproduce this issue I have followed the steps below:

1. Open below post in Edit mode:
hidden link

2. Select ‘page_builder_0_class’ custom field as Translate from bottom of the page.

3. Press ‘Apply’ button from bottom of the page.

4. Press ‘Update’ page button.

Custom field is saving correctly with above steps. Could you please try above and let me know how it goes?

If still issue persists, please let me know the steps how to reproduce this issue.

Thank you

The topic ‘[Closed] Set custom field as "translate" wont save on post edit screen’ is closed to new replies.