Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Bigul 1 month, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
October 23, 2020 at 6:57 pm #7296615

carlos-helderG

This is the continuation of a ticket that was closed because I could not answer on time. This ticket: https://wpml.org/forums/topic/set-prices-in-other-currencies-manually-not-working-2/

So you're right, if I configure it as: WooCommerce>>Settings>>Tax - Calculate tax based on>>Shop base address

Then it gets the secondary currencies correctly.

Yesterday I got an answer from WooCommerce support team which helped me to understand what's going on: https://wordpress.org/support/topic/yes-i-will-enter-prices-inclusive-of-tax-not-working-well/#post-13573701

So this is the problem:

1A) If I set it as Shop base address, it gets the prices that I've setup.
1B) Unfortunately, the taxes will be the taxes of the shop base. So, in our case, it will be 21% no matter of the customer's country.

2A) If I set it as Customer shipping address, the taxes will be the actual taxes that the customer have to pay in his/her country.
2B) Unfortunately, the prices shown to the customers won't be the ones configured, but weird prices instead (see the previous wordpress.org/support link to know why).

So any solution to configure it with the customer country taxes and show the prices correctly? 🙁

October 27, 2020 at 3:38 pm #7318437

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Carlos,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue. Sorry for the delay that happened because of the weekend and the long queue.

Thank you for the updates. I will consult about this with our developers. So please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please refer to the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

October 29, 2020 at 9:22 am #7332601

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Carlos,

Thank you for the login information. I made a new Duplicator copy of the site and working on it locally now. Will consult with our second-tier team and get back to you as early as possible. Please wait.

--
Thanks!

Bigul

October 30, 2020 at 11:02 am #7342565

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Carlos,

Please check my last message. It is marked as private. I have created a test space in Cloudways for debugging and tracing the issue. Please find the details in the previous reply. So we can troubleshoot the issue without affecting your live site. Thank you for your understanding.

--
Thanks!

Bigul

October 30, 2020 at 4:49 pm #7345357

carlos-helderG

Actually I see the same troubleshot on the staging site you have created!

I've recorded a video to show you: hidden link

I hope that helps!

Thank you Bigul! 🙂

Carlos

October 30, 2020 at 5:46 pm #7346247

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Carlos,

Thank you for the feedback. I have shared the details with our second-tier team and waiting for their feedback now. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

November 9, 2020 at 1:44 pm #7408885

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Carlos,

Our developers had detailed testing on this after upgrading to the latest version of WooCommerce. But the issue is existing when WPML plugins are inactive. The result is the same in the sandbox site also. It looks like the issue is only happening with the login users. It shows the correct result for the guest users.

Please visit the following screencast URL and the sandbox site for more details.

hidden link

Test Product:- hidden link

--
Thanks!

Bigul

November 9, 2020 at 1:59 pm #7408957

carlos-helderG

You say that the result is the same when WPML plugins are inactive:

I know! Actually I shared with you the answer of Woocommerce support related to that: https://wordpress.org/support/topic/yes-i-will-enter-prices-inclusive-of-tax-not-working-well/#post-13573701

So let me repeat: this is the problem:

1A) If I set it as Shop base address, it gets the prices that I've setup.
1B) Unfortunately, the taxes will be the taxes of the shop base. So, in our case, it will be 21% no matter of the customer's country.

2A) If I set it as Customer shipping address, the taxes will be the actual taxes that the customer have to pay in his/her country.
2B) Unfortunately, the prices shown to the customers won't be the ones configured, but weird prices instead (see the previous wordpress.org/support link to know why).

So any solution to configure it with the customer country taxes and show the prices correctly? 🙁

November 9, 2020 at 6:25 pm #7410883

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Carlos,

Thank you for the feedback. As per our testing, there is a tax calculation issue when the WooCommerce is the only enabled plugin.

So I have a request. It will be great if you can share a screencast that shows the exact issue happening because of WPML or WooCommerce Multilingual on our Sandbox site - hidden link

It will help us a lot in debugging. Thank you for your understanding.

--
Thanks!

Bigul

November 9, 2020 at 6:35 pm #7410907

carlos-helderG

There is NOT a tax calculation issue when the WooCommerce is the only enabled plugin.

They do it on purpose: please read the Woocommerce support explanation.

November 10, 2020 at 7:00 am #7413679

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Carlos,

Thank you for the updates. I will consult about this with our developers and get back to you soon. Please wait.

--
Thanks!

Bigul

November 23, 2020 at 9:11 am #7506813

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Carlos,

We will consider this a feature request and will try to implement it in the future version of WooCommerce Multilignual. But as of now, we don't have the exact time frame required for this. Thank you for your understanding.

--
Thanks!

Bigul

July 31, 2021 at 9:45 am #9319687

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We are closing this ticket now. Because as of now it is a feature request and there is no exact time frame schedule for it.

If you still have similar issues, please feel free to open a new ticket. We are happy to help always. Thank you for your understanding.

--
Thanks!

Bigul

The topic ‘[Closed] Set prices in other currencies manually NOT working (2)’ is closed to new replies.