Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Change the existing main language content into the secondary language content without having to do one by one

Solution: With Translation management it is easy to batch-duplicate all 43 pages without having to do it one by one

You can also try to go to WPML=>Support=>Troubleshooting and perform the clean up options if this doesnt fix the issue then i recommend using Translation management to batch-duplicate the pages

This topic contains 6 replies, has 2 voices.

Last updated by J Francisco Gonzalez 3 years, 9 months ago.

Assigned support staff: Bobby.

Author Posts
February 8, 2016 at 1:52 pm #807303

J Francisco Gonzalez

Hi there,

I have the content on my site in Catalan, but when I installed the WPML I selected Spanish as my default language. But now I want to change the main language to Catalan without duplicating pages and other info. Tried steps from this topic https://wpml.org/forums/topic/set-language-for-existing-content/ , but they didn't help me.

Thanks a lot in advance.

February 8, 2016 at 10:43 pm #807713

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for contacting WPML Support,

May I kindly ask you to go to WPML=>Languages and from there set "catalan" as a default

Also go to WP=>Settings=>General=>Language and set your language to Catalan

Please let me know your results,

Kind Regards,
Bobby

February 9, 2016 at 8:12 am #807863

J Francisco Gonzalez

Hi there Bobby,

I had WordPress 3.9 and there is missed the Language section here WP=>Settings=>General=>Language. However, I've updated to the 4.4.2 and done requested steps, but unfortunately it didn't help.

Thanks,
Alex.

February 9, 2016 at 5:48 pm #808533

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi Alex,

May i kindly ask you to please update your WPML and its add-on plugins to their latest versions

=> https://wpml.org/account/downloads/

You will need to manually update your plugins to the latest version please review the following documentation
=>https://wpml.org/2015/06/wpml-3-2-released/

Please let me know your results

Kind Regards,
Bobby

February 10, 2016 at 12:15 pm #809230

J Francisco Gonzalez

Hi Bobby,

Just updated and my pages are still in Spanish section, please check the screenshot.

Can you kindly tell me how to reset its language to Catalan?

Thanks a lot.

February 10, 2016 at 6:14 pm #809626

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for the screenshot!

The easiest way and might be the only workaround to resolve this would be to duplicate the pages/posts , is there a specific reason why you would like to avoid that option

With Translation management it is easy to batch-duplicate all 43 pages without having to do it one by one

You can also try to go to WPML=>Support=>Troubleshooting and perform the clean up options if this doesnt fix the issue then i recommend using Translation management to batch-duplicate the pages

Please let me know your results,

Thank you,
Bobby

February 11, 2016 at 12:17 pm #810332

J Francisco Gonzalez

Hi Bobby,

Thanks a lot for your help!