Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by jean-paulS 9 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
March 5, 2019 at 8:54 am

jean-paulS

I am trying to: use a different parked domain for the Dutch (NL) pages of my bilingual website but got the “not valid” message. I already searched for similar topics on your forum, but can't find the solution. I deactivated all my plugins (except for WPML CMS of course) and activated the default theme “Twenty Nineteen,” but the issue remains. I also unchecked the "validate on save" button before saving, and then it says the data are saved. But when I try to go to a Dutch webpage, I got the warning from the browser that the website is not correctly configured and that it is not save.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

March 6, 2019 at 12:19 pm #3278845

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome back,

I have accessed your site and observed that you are trying to use the domain jouwindiversum.net for NL translation, the domain(jouwindiversum.net) already have a copy of WordPress installed and it is not pointing to the default domain (hidden link) hence you are getting a validation error.

The idea is to use the same installation and just map a different domain for a different translation.
You have to point the domain "jouwindiversum.net" to the default language (hidden link) IP address.

We have detailed documentation on how to set up the different domains per language with WPML, Please refer https://wpml.org/2016/04/use-wpml-different-domains-per-language/ .

I hope this helps you better, let me know if you need further clarification. I will be happy to help you.

Kind regards
Raja

March 6, 2019 at 3:10 pm #3279896

jean-paulS

Hi Raja,

Thanks for your reply. I don't know what you exactly mean by "pointing to the default domain."
In the documentation about setting up a different domain, there is written:
"In order for your settings to work, you need to create an entry in your web server that will recognize the domain name (or the sub-domain name) that you have just added and pointed to in your DNS server.

If you are running and administrating your own server, it is pretty easy – you just need to add server alias to your current configuration.

Following is an example used for the Apache server setup.

DocumentRoot "/var/www/www.example.com/webroot"
ServerName example.com
ServerAlias example.de
..."
Sorry, but I don't understand this. Could you help me a little further with this?

In cpanel, above my lists of parked domains, it says:
"NOTE: You must register your domains with a valid registrar before you can park them. Also, they will not function properly unless you configure them to point to your DNS servers."

Is this pointing to the DNS servers the same as what you mention? But also here, I don't know how to do this.

Note that "jouwindiversum.net" was already set as a parked domain in cpanel. The documentation you refer too says (after creating a parked domain): "All settings for your Apache and DNS will be created and added by Cpanel and everything should work."

March 7, 2019 at 6:34 am #3282477

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

Let me simplify this, The parked domain is a domain hosted in your same account but make sure it uses the same path for your site .

For example, If the webpath of yourindiverse.net is "/www/public_html" the path of "jouwindiversum.net" should also be the same. Which I mentioned it as pointing it to the default domain.

As of now the domain, jouwindiversum.net opens a separate site which means it has a different path. it should open the site "hidden link" when the DNS settings are correctly added.

I would suggest leaving the work to your hosting provider, They are the right person to handle this ask them to fix the DNS settings for you. They can understand the documentation very well https://wpml.org/2016/04/use-wpml-different-domains-per-language/

If you need further help, leave me a message I will be happy to help.

Kind regards
Raja

March 7, 2019 at 7:34 am #3282644

jean-paulS

Hello Raja,
As you can see in the screenshot, "jouwindiversum.net" has the same path as "yourindiverse.net." Nevertheless, this doesn't work. I will contact my hosting provider to see if they can fix this.
Kind regards,
Jean-Paul

March 7, 2019 at 9:12 am #3283045

jean-paulS

Hi, Raja
Siteground support could fix the issue. Seemingly, "jouwindiversum.net" had not an SSL dedicated to it. They reinstalled it for all the domains, and now it's ok.
But now I see that my images on the Dutch posts and in the media library (when the language is set to NL), are not showing up.
It's only on the posts pages (and of course the carousel on the home page) that the images are missing. The other NL pages are ok. When in the media library, I set the language to EN, the images reappear.
Any idea what could be the cause?

March 7, 2019 at 2:09 pm #3284829

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I am requesting assistance from the second tier for a detailed look into the issue. I will let you know soon once I have an update form them.

Kind regards
Raja

March 7, 2019 at 3:49 pm #3285525

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have escalated the issue to our second tier of supporters, they are looking into the issue, I will let you know soon once I have an update form them.

kind regards
Raja

March 8, 2019 at 9:20 am #3290446

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI there,

I have got a response from our second tier support George.

The problem is the plugin: Adaptive Images for WordPress
DIsabling it fixes the issue.

Please confirm the same.

Kind regards
Raja

March 8, 2019 at 9:47 am #3290764

jean-paulS

Hi Raja,
It’s the plugin indeed. All works fine when it’s disabled.
There’s still one issue left, however, which I didn’t mention earlier. When in languages, I choose a different domain for my Dutch pages (“jouwindiversum.net”), and I choose a page to edit, clicking on “preview changes” gives the error message: “Sorry, you are not allowed to preview drafts.” This message appears with all the pages, but not with the posts, which I can preview without a problem. When choosing “Language name added as a parameter”, the previewing works normal.
Setting my site to life (disabling the maintenance plugin) doesn’t solve the issue. I also disabled all my plugins (except for the WPML plugins), but in vain. And I already cleared my browser cache. But since the fact that it works with “Language name added as a parameter,” the problem should lie elsewhere.

March 8, 2019 at 3:14 pm #3293516

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi jean-paul,

I am unable to access the site to check the issue.
However, I’d recommend flushing your browser’s cookies.
If that doesn’t help, could you try to deactivate the WPML plugin, and see if the problem remains?

Let me know how it goes!

Kind regards
Raja

March 8, 2019 at 8:26 pm
March 11, 2019 at 6:28 am #3307875

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jean-paul

I have disabled "Auto sign-in and sign-out users from all domains" in language url settings which solved the issue. I am able to preview the NL draft.

I hope this solves the issue.

Kind regards
Raja

March 11, 2019 at 8:05 am #3308233

jean-paulS

Hi Raja,

It works, indeed. The only thing is that when previewing the Dutch pages or posts, the logo remains the English one (because in the URL it's "yourindiverse.net," as you can see in your screenshot), but that's not really a problem: the "real" pages and posts have the right logo.
I think all the issues about the different domain per language are now solved 🙂
Thanks for the excellent support and have a nice day!

Kind regards
Jean-Paul

March 11, 2019 at 8:07 am #3308247

jean-paulS

My issue is resolved now. Thank you very much!