This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Otto 3 years, 10 months ago.

Assigned support staff: Otto.

Author Posts
December 21, 2015 at 10:32 pm #774295

georgG

Hi again,

Consequent to my other thread regarding messed up URLs, in the process of fixing them [must wait for next update], when I go to Settings > Reading and try to set the static page for home page correctly [it went wrong], then no way to save the changes. It always resets to the wrong page [Aide] instead of the correct one [Accueil] - this worked fine before latest upgrades - see my previous topic.
Dat has asked me to open a new ticket for this one, so I did.
Thank in advance,
G.

December 22, 2015 at 5:16 pm #774950

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello G.,

Thank you for contacting the WPML support!

Please apologise for the delay in answering. This is not usual in this forum. I'll take care of your ticket and reply time will be shorter from now.

Can you please increase the memory limit to 256MB:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Your configuration now is 40M and the minimum requirements are 128M

Can you please update WPML and it´s add ons to their latests versions and let me know if the issue persists after that? Please back up your site before updating.

Also, can you please update the Divi Theme to it´s latest version and check if the issue persists?

If the issue persists, can you please do the following test:
-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

Thank you for your time and cooperation to debug this issue.

Let me know your results please.

Kind Regards,

Otto

December 22, 2015 at 8:02 pm #775085

georgG

Hello Otto,

I've followed the steps, including installing a memory usage display plugin in the footer of wp-admin pages. Even after adding the line
define( 'WP_MAX_MEMORY_LIMIT', '256M' );
to the wp-config.php the mem limit displays still 40MB -- but about this I've just replied to DreamHost support.

On the front page matter now:
1. updated WPML [all of them] to latest; Divi was already up to date;
2. deactivated all other plugins, changed the theme to Twenty Fifteen - then went to Settings > Reading to change the front page field from 'Aide' to 'Accueil' -- it didn't work;
3. went back to deactivate even all WPML plugins -- then back and finally the 'Accueil' page selection is saved [excellent!] - It worked!
4. switched back to Divi theme -- the 'Accueil' page in place on home, wonderful.
5. reactivated the WPML related plugins -- dang!, the 'Aide' page surged on the home page, like before.
So the bug remains and manifests only when WPML plugins are active.

Please help!
Thanks a lot,
G.
PS - Hope that you are using the access data that I've previously provided to Dat in the ticket before [they are the same]. Thanks again!

December 23, 2015 at 11:58 am #775489

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you very much for the testing and the detailed explanation.

I would like to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

Kind Regards,

Otto

December 23, 2015 at 2:05 pm #775597

georgG

Hi Otto,
Perfectly okay.
Godspeed!
🙂

December 23, 2015 at 6:16 pm #775785

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello G.,

I made a local copy of your site and surprise: it works like charm.

So this is really strange.

Before I escalate the issue to our second tier support can you try this:

If the issue persists, can you please go to WPML > Support > Troubleshooting and perform all the actions of the "Clean up" section? Take a look at the screenshot attached please.

***Don't ignore the back up warning***

Let me know your results please.

Kind Regards,

Otto

December 24, 2015 at 5:50 pm #776341

georgG

Hi Otto,

After starting Varnish, things got to work here too.
Thank you very much for your help.
Merry Christmas to you and the entire WPML team!
G.

December 24, 2015 at 6:06 pm #776345

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Thanks G.!

I´m really glad it is working now.

Merry Christmas!