Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.


This topic contains 3 replies, has 3 voices.

Last updated by Dražen Duvnjak 2 months, 2 weeks ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
September 8, 2020 at 3:29 pm #6967751


Tell us what you are trying to do?

Setup a multiple domain site for each language

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

hidden link

September 9, 2020 at 11:30 am #6975193

Bruno Kos

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)


Thank you for contacting WPML support!

While you are waiting for one of my colleagues to take this ticket and work on it, let me provide you with first debugging steps or if I can perhaps help with the issue quickly.

Would you mind updating WPML plugins to the latest versions before we resume checking this out?

Also, sometimes these warnings are false positive - can you tell me what happens (after you update plug-ins of course) if you disable the "validar en guardar" option and save the language URL option and then check any translation into other languages if these URLs perhaps work, regardless of the warning.

Bruno Kos

September 10, 2020 at 8:45 am #6982595


Hi Bruno,
I've just updated the plugins and disabled "validar en guardar" option, right now when I click on the spanish language it appear an empty site. ¿Could you give me some more instructions to solve it?

September 10, 2020 at 12:38 pm #6985035

Dražen Duvnjak

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)


thanks for the feedback.

I will be taking over this ticket.

This could probably mean the Spanish domain is not set up properly. Let's make sure the domains are set up correctly and showing the same WordPress website. Also, make sure you have an HTTPS certificate setup on the .es domain since it is now showing there is no active one.

Please follow the next steps:

Please make a backup before proceeding.

1) Disable WPML plugins
2) Create some test.txt in notepad on your PC, with text saying for example "This is the same file."
3) Now upload this file using FTP or Cpanel to the root of your website (public_html/)
4) With WPML disabled when you visit both domains it should show the same file. This would mean the domains are set up correctly and showing correctly the same website/WordPress installation.



5) If showing the same file when you enable and set up WPML settings it should work fine.

If you need assistance with setting up your domain correctly please contact your domain / hosting support and make sure it is showing the same file with WPML disabled.

Please let me know how it goes and don't hesitate to ask if you find any problem along the way or have doubts or questions about the steps mentioned above, I'll do my best to help you in the best way possible.


The topic ‘[Closed] Setup a multiple domain site for each language’ is closed to new replies.