Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Setting a page as a parent does not work on the translated page.

Solution:

By mistake, the page wad in the trash section. Byt recovering it from the trash section, the problem git solved.

Relevant Documentation:

This topic contains 5 replies, has 2 voices.

Last updated by mennoB-4 1 month ago.

Assigned support staff: Itamar.

Author Posts
October 31, 2019 at 11:54 am #4863321

mennoB-4

I am trying to:

setup "marine" parent page (2 lang - en) in the page
/en/shipping-terminals/

parent page "marine"
/en/marine/

Link to a page where the issue can be seen:

hidden link

I expected to see:
hidden link

Instead, I got:
hidden link

October 31, 2019 at 12:11 pm #4863429

mennoB-4

... the language flag does not appear on the menu in both versions of the page.

November 3, 2019 at 1:15 pm #4876735

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I can see the issue on your site.

It seems that there is a 301 redirection where you expect to see URL with a parent. I can see it when I use the browser's console when I navigate to this URL.
hidden link
Please check for any redirection directive. I can see that you are using the Simple 301 Redirects.
Is it possible that you have added this 301 directive there?

Regards,
Itamar.

November 4, 2019 at 9:09 am #4878861

mennoB-4

Hi, Thanks for the msg.
This page is not included in the 301 redirect
By accident this page was in the trash. Maybe this is the problem?
Thanks

November 5, 2019 at 5:34 pm #4892285

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Yes, this might be the problem. Please recover the page from the trash section and see if it helps.

Thanks,
Itamar.

November 7, 2019 at 7:21 am #4903127

mennoB-4

My issue is resolved now. Thank you!