This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Andre Koebel und 2 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
August 5, 2019 at 3:12 pm #4341567

Andre Koebel und

When we try to initialize the Translation Management (Click on WPML - Translation Management) it will throw a 404 and stop loading the Page:

VM1122:1 GET hidden link 404
Uncaught (in promise) Error: Es wurde keine Route gefunden, die mit der URL und der Request-Methode identisch ist.
at app.js?ver=2.8.6.2:39

Check the screenshot.

August 5, 2019 at 10:16 pm #4343157

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

there might be a compatibility between WPML Translation Management and a 3rd party plugin causing this behavior

usually i do not recommend to deactivate/activate plugins on a live site but if you have a staging environment please try the following

-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty 19.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

Let me know your results please.

If you do not have access to a staging environment please let me know and i can create a duplicator package to test locally or migrate the site to our staging servers to further test without interfering with your site

If possible i would like to take a closer look at the backend to further test this issue

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 6, 2019 at 9:01 pm #4350505

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

i deactivated/removed the WPML Translation Management plugin and replaced it with a fresh download from https://wpml.org/downloads/

and it seems to work as expected now

let me know your results please

August 7, 2019 at 5:05 am #4352083

Andre Koebel und

Hey, not really. :/ In our Livesystem it doesnt fix the Problem. How can i give you access to this installation? I have no form to give you the login details.

August 7, 2019 at 6:35 am #4352271

Andre Koebel und

Hey,

we now have access to the translation manager, but the error "no route found" still exists, we can do nothing. :/

Please let me know hot give you access to our live system to fix the problems.

August 7, 2019 at 7:42 am #4352521

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

i have enabled the private field reply.

is the issue resolved in the staging environment?

August 7, 2019 at 9:06 am #4353029

Andre Koebel und

Yes, please try to delete a translation in the "jobs" Tab or try to give a "job" to another person, it will not work.

August 7, 2019 at 7:30 pm #4357693

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I believe it should be ok now

Within WPML->Translation Management you can assign jobs and also you can cancel them now.

once a job is finished the "X" will be greyed out and you can no longer cancel it. Finished jobs remain in the translation jobs tab.

you can also assign a job but once you assign it until either you cancel it or the translator resings you cannot re assign the job again.

To resolve the issue with the "X" button not allowing you to cancel a job i went to WPML->String Translation->searched for Local and made sure the translation was set to "Local" for all languages

August 8, 2019 at 12:26 pm #4362807

Andre Koebel und

My issue is resolved now. Thank you!