This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
September 25, 2018 at 9:07 pm #2765271

raineyT

Tell us what you are trying to do?
I just instal wpml to my website, I already activate. I'm trying to setup it but it looks like froze in the step 3: language swticher
Is there any documentation that you are following?

Is there a similar example that we can see?
I found this, but it wasn't that helpfull: https://wpml.org/forums/topic/setup-hangstuck-on-3-language-switcher/
What is the link to your site?
dev

September 26, 2018 at 8:52 am #2766494

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

There are a few things we can try to fix this. I will list them below and please retry the setup after taking each of the steps.

1. I have noticed that your website’s WP Memory Limit (which is different than the php memory) is 40MB.

We will need to increase that as the minimum requirements for WPML are 128Mb:
https://wpml.org/home/minimum-requirements/

Please add the lines below to the top of the wp-config.php file to increase WP memory:

/** WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Retry the setup.

2. Clear the Autoptimize cache and then disable the plugin. Retry the setup.

3. If the issue will still persist, there might be a possible theme and plugin conflict situation.

In order to fix this you can:

- switch back to any default theme (e.g. Twenty Sixteen theme)
- Disable all the non-WPML plugins
- see if this issue goes away with default theme and only WPML plugins activated
- If after you do that, things work well try to enable the plugins you just disabled, one by one and this will help you find the plugin that causes the issue.

Let me know how this goes and if you still need help.

September 26, 2018 at 3:33 pm #2767957

raineyT

I tried the steps you suggested but, I am still getting the same issue. I turned on the WP_Debug and I am getting the following Fatal Error, when going on the Language Switcher step.

Fatal error: Uncaught TypeError: Argument 1 passed to WPML_URL_Converter_Parameter_Strategy::get_query_args() must be of the type array, boolean given, called in /mnt/stor3-wc2-dfw1/512462/2018101/dev.sphericassurance.com/web/content/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-parameter-strategy.php on line 15 and defined in /mnt/stor3-wc2-dfw1/512462/2018101/dev.sphericassurance.com/web/content/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-parameter-strategy.php:38 Stack trace: #0 /mnt/stor3-wc2-dfw1/512462/2018101/dev.sphericassurance.com/web/content/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-parameter-strategy.php(15): WPML_URL_Converter_Parameter_Strategy->get_query_args(false) #1 /mnt/stor3-wc2-dfw1/512462/2018101/dev.sphericassurance.com/web/content/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/conv in /mnt/stor3-wc2-dfw1/512462/2018101/dev.sphericassurance.com/web/content/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-parameter-strategy.php on line 38

Any ideas on what could be going wrong? Thank You

September 26, 2018 at 7:22 pm #2768474

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

In order to further investigate this, I will need temporary access (wp-admin and FTP) to your site to take a better look at the issue. A testing site where the issue is replicated would also be helpful.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved, I will delete the local site.

Let me know if this is ok with you.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields, this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this:
hidden link

October 1, 2018 at 3:07 pm #2778585

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I was able to do a few more tests and I found some new data that we need to take into consideration.

For the moment your site is using an outdated version of MySQL on your server. The minimum recommended version is MySQL version 5.6 (and above).

Also for both the live site and the staging site, the WP memory is still 40MB so we need to raise that at at least 128MB.

Here is the list of WPML requirements:
https://wpml.org/documentation/support/debugging-wpml/

So, what I will need you to do is this (retry the WPML setup after each step):

1. Update the MySQL version to at least v5.6 (an admin of the server can do that usually)
2. Raise the WP memory to at least 128MB

You can add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly. If you can get even higher values (like 256MB) it would be even better.

Please let me know if this solved your issue or if you still need help.

October 1, 2018 at 3:37 pm #2778647

raineyT

Oh sorry, I forgot to add the Memory Size Limit code snippet when creating the test site. I went ahead and added it to the config file but, issue persists.

As for the MySQL version we actually do not use MySQL we use MariaDB which for this website is on ver. 10.1. Is that the issue? Is the database not compatible. As for WordPress it would not work on any MySQL version below 5.6 or MariaDB below 10.0.

October 2, 2018 at 12:51 pm #2781459

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Let's try this, too:

- disable all the other plugins
- enable a WP default theme (like Twenty Seventeen)
- reset the WP setup (Go to: WPML > Support > click the 'troubleshooting' link > scroll down till you see the "Reset" section > check the "I am about to reset all translation and language data" checkbox > click the blue "Reset and deactivate WPML" button
- now go to Plugins and enable WPML back
- go through the WPML setup once again

Please let me know how it goes.

October 2, 2018 at 1:21 pm #2781616

raineyT

I just tried that again, thinking maybe it could work with the fresh test website but, I get the exact same issue.

October 2, 2018 at 2:47 pm #2781927

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

I see.

To further debug the problem I will need to replicate your site locally.

I downloaded the duplicator package and will get back to you as soon as I have more information on this.

October 3, 2018 at 10:06 am #2784137

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for waiting.

I am not able to reproduce the issue on my local server. I started straight with step 3 and went through all the next steps.

This seems to confirm that there's an issue with the server where your site is hosted on at the moment.

It might help to get in touch with the hosting company and make sure your server setup is meeting all the WPML requirements:
https://wpml.org/home/minimum-requirements/

October 3, 2018 at 1:28 pm #2784713

raineyT

Unfortunately, I had already done that and was told it was probably the plugin causing the issue. It might just be the compatibility with MariaDB instead of MySQL.
What it the process for a refund? I just purchased the license not to long ago and since, we cannot figure out what is causing the issue I would like to refund my purchase as I was never able to use it as it was intended.

Thank You for trying though. I appreciate it.

October 3, 2018 at 2:17 pm #2784799

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Yes, there's some incompatibility happening with your site's server setup as on my local things work as expected.

If you are eligible, you should be able to ask for a refund from your own WPML account at this link here (make sure you log in first):

https://wpml.org/purchase/refunds-policy/

I'm also attaching a screenshot so that you can find that section on the site after you log in.

Please let me know if there's anything else I can help you with or if this is all that you need for the moment.