Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Bigul 7 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
April 23, 2019 at 6:00 pm #3666693

jamesM-38

Hi,

1. The first issue I have is that an ACF field titled "Property Summary" is only showing up for English translations even though it's set as being translatable in the ACF field options and on the property editing screen.

2. The primary language of the site is French and translations are in English. On some English translated posts the editor is the classic editor (see screenshot 1) and on other it's the streamlined WPML editor (see screenshot 2). How can I make them all like screenshot2?

3. I don't want the property gallery image titles to be translatable. I have them set to copy on the post editing screen however they titles still show up on the translation page?

4. Do you know why the admin language has changed to French from English? I haven't done this but it seems to be automatic and I can't understand anything.

5. Is there a way of disabling the language switcher in the toolbar at the top of the admin area and the panel on right in the post editing screen so an admin can only add translations on the main posts list page by clicking the + symbol next to each post? I think this is causing my client a lot of confusion as they don't know where to go as they have so many options.

6. Originally the default language was English and the secondary language was French. Around 80 posts were added when the site was setup like this. Since the default language was changed the "Gallery" ACF field has stopped working on some of these posts. For example this post - hidden link even though images have been added in the WordPress dashboard (see screenshot 3).

For the property post types (which is where all the problems are) I just want the default language to be "French", and for the admin to use the streamlined editor to enter translations for the page/body content and the property summary ACF field. Everything else can be copied across.

April 23, 2019 at 8:38 pm #3667581

jamesM-38

I've managed to resolve point 4 since I wrote the above post but I'm still having problems with the other points.

Regards,

James

April 24, 2019 at 8:34 am #3670429

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi James,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

We have released a new version of WPML(4.2.6) yesterday. Have you upgraded to the latest version now? If not, please upgrade to the latest version after a full site backup and make sure the issues are existing or not.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

Please note, as per our support policies we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. So I will be creating new tickets for it. Thank you for your understanding.

--
Thanks!

Bigul

April 24, 2019 at 10:33 am #3671583

jamesM-38

Hi,

Thanks for the reply, yes I've updated everything to the latest versions available.

The main issue I have is with the property posts, around 80 were created originally when the primary language was English and the secondary language was French. Since the languages were changed over so French was the primary one the image galleries for them no longer work.

Could you take a look for me please?

Thanks,

James

April 24, 2019 at 4:18 pm #3675061

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi James,

Thank you for the updates. Please update a couple of the property posts in both languages(just resave to refresh the translation settings) and make sure you are getting the expected result or not.

Have you changed the original language of Property posts to French from English?

Please try it and let me know your feedback.

--
Thanks!

Bigul

April 24, 2019 at 5:08 pm #3675467

jamesM-38

Hi,

Yes I've updated both language translations and it's made no difference.

The original default language was English which has since been changed to French.

Regards,

James

April 24, 2019 at 5:10 pm #3675475

jamesM-38

Just to clarify new posts seem to be fine but older posts created under English (as the default language) aren't showing any ACF image galley images in either language.

April 24, 2019 at 5:50 pm #3675683

jamesM-38

I'm also not able to add images to the ACF gallery fields on these older posts. When I add an image and save the post the images aren't being saved.

April 24, 2019 at 6:37 pm #3675975

jamesM-38

I'm still waiting for a reply to this, why is it taking so long to get answers?!

April 25, 2019 at 5:40 am #3678903

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi James,

Thank you for the feedback. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

April 25, 2019 at 10:01 am #3680875

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi James,

Thank you for the login information. This may be happening because of the sync issues after switching the default language. Please try the following steps after a site backup and let me know your feedback.

1) Open a Property post(having issue) for edit in French
2) Choose *none* for *This is the translation of* field of *Language* widget(on the right side of the screen)
3) Update the post
4) Visit the post in frontend and check you are getting the expected result
5) Open the English Property post(translation of French) for edit
6) Then connect it to the French post(from the Language widget)
7) Set French as the original language
8) Visit the posts in the frontend and check you are getting the expected result or not

--
Thanks!

Bigul

April 25, 2019 at 12:59 pm #3682635
jamesM-38

Hi Bigul,

Thank you, that seems to have worked, are you able to help with my next issue?

An ACF field on the site titled "Property Summary" should be showing on both the English and French versions. It's on the French version but only on the English version when the advanced translation editor is selected, if the classic editor is selected it doesn't appear?

Kind Regards,

James

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-an-acf-field-is-not-showing-as-expected/

April 25, 2019 at 3:50 pm #3684185

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi James,

Thank you for the feedback. I have opened a new ticket for the Property Summary issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. I will get back to you soon on the new ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul

The topic ‘[Closed] Several Issues with WPML’ is closed to new replies.