This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Shipping method translation is not showing on front-end

Solution: Changing the language of the string and translating it solve the issue.

This topic contains 2 replies, has 2 voices.

Last updated by zsoltE-2 1 month, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 5, 2019 at 9:24 am #4517637

zsoltE-2

Hi,

My default language is Hungarian, second is English. I use Woocommerce and WPML. I translated the shipping methods (see attachments), but those strings are still in Hungarian in the frontend (cart and checkout pages).

Would you please help me out? Maybe a forgot something.

Regards, Zsolt

September 5, 2019 at 9:42 am #4517939

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have enabled the private reply for you, please provide the duplicator package in the next private reply.

Thanks

September 5, 2019 at 10:31 am #4518449

zsoltE-2

I have found the reason. As you can see in the String Translation screenshot, the language of "GLS futárszolgálat" string was set to English (who know why? ). I changed to Hungarian and translated to English. Now it works.