This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 33 replies, has 2 voices.

Last updated by Yvette 1 year, 5 months ago.

Assigned support staff: Yvette.

Author Posts
April 10, 2018 at 5:55 pm #1585544

Albin

I am trying to: Update translation for woocommerce shop

Link to a page where the issue can be seen:hidden link

I expected to see: A shop

Instead, I got: Blank

Here is my prob:
Almost every time I update my shop (from swedish to english) it doesn't show up online anymore.

Whats also different is that it changes from the english module name "shop" to the swedish module name "butik" in the english translation. Also the categories in the english shop module are swedish. Sometimes it changes back by it self. I have no idea why.

Right now the shop is visible on the english page cos I set it up manually to not loose customers, but next time I will change the Swedish shop and click on the little pen to update the english version it will crash and not show again.

April 11, 2018 at 7:31 am #1590355

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

From what you write, I understand that you are able to recreate the issue on demand.

1. Supporting your site
I understand that investigating the cause of this problem will cause site downtime for you.
In this case, the best way forward is for you to use the Duplicator plugin to provide a snapshot of your site that I can install on a local server and debug.

Duplicator is free and relatively easy to use. If your site is very large, you can use the filters to not include the directory wp-content/uploads/

I am opening the private area for you to send me a downloadable link to a filesharing platform where you have uploaded the Duplicator "package". The private are is only visible between you and WPML Suppport.

2. Steps to replicate the issue
Please be very very specific and include snapshots where it makes sense to do so.

Thanks for your collaboration on this.

April 11, 2018 at 11:36 pm #1602606

Albin

I have tried both we.tl and dropbox, ur site don't accept any link

April 12, 2018 at 7:19 am #1604501

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Sorry - you will need to actually place the files on those services and then send the link to those files to us.

Is this more clear?

The reason is because our forum has a file upload limit of 1M and the duplciator packages are understandably much much larger.

April 12, 2018 at 5:41 pm #1613021

Albin

Hello again
I uploaded the files to both Dropbox and we.tl and the links was not accepted in this form.

April 13, 2018 at 6:49 am #1617299

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

That is very strange! I´ve not heard of this problem before.

You can send an email to this temporary email address: <removed>
Include the links there. Normally the email channel is restricted but in this case, I see it would be necessary to advance.

Please reply here once the email has been sent so I will know to go look for it.

Thanks

April 13, 2018 at 11:49 am #1621353

Albin

sent 2

April 13, 2018 at 1:25 pm #1623067

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Got them. Thanks

April 13, 2018 at 6:14 pm #1626264

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I was able to install your system snapshot. I then eecuted the following steps:

1. Edit the SE "Selina's Bazaar" page
2. Make a change in the first page builder module
3. Update
4. Select pencil to update the EN "Selina's Bazaar" page
5. Enter Translation Editor and complete translation
6. View both Se and EN shop pages

On my local installation - everything worked fine. The shop pages were the same after the updates

Did I execute the right steps to replicate the issue you are experiencing?

Thanks for advising.

April 13, 2018 at 10:50 pm #1627304

Albin

I tried again and the problem remains.
I will show you step by step with print screens.
Order of print screens is starting from the first one I uploaded (bottom right image).
Ending with 0.47.01 where I have to click on all categories again.
Notice that in image 0.45.59 it shows the swedish module name "butik" instead of "shop".
Usually all the categories are in swedish to after I update the translation in english. This time this did not happen, I don't know why.

April 13, 2018 at 11:06 pm #1627320

Albin

Actually. Right after I wrote the last reply to you the problem starts to show on the swedish shop page. Im showing you a print screen. U can see its the swedish page (blue yellow flag in top), and you can see all the categories are now in english. And the swedish shop page is now not showing.

April 16, 2018 at 1:22 pm #1646942

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I am still unable to replicate this behaviour on my local copy of your site. But, I do see from your screenshots that the shortcode [et_pb_shop] is not translating the attribute "included categories" .

Could we do the following so as to not interrupt your shop but to still be able to investigate the issue?

Please create another page that has the same structure as your shop. In fact, all it has to have is the one shortcode [et_pb_shop] Set this to be visibility of "private". Then see if this page behaves in the same way as your normal shop page.

If it does, please send me system access details so that I can investigate it on your site.
I am opening the private area for these details.

Thanks.

April 16, 2018 at 5:46 pm #1650378

Albin

Yesterday i also got this warning

April 17, 2018 at 12:30 pm #1660877

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I believe the issue was happening because the attribute "include_categories" was not translated properly. In an English page, attempting to display SE categories will result in a blank page (e.g. no products).

I´ve added the following entries in the tab:
WPML -> Translation Management -> Custom XML Configuration

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>et_pb_shop</tag>
            <attributes>
                <attribute>admin_label</attribute>
                <attribute>include_categories</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

This will now parse the attributes of admin_label and any included categories that might have been selected so that you can "translate" them.

Note that the product categories will be listed by their ID number. This means that you should create a table for yourself that has the ID numbers of the categories in SE and their corresponding ones in EN. You can find this out by going to Product -> Categories.
Choose a category to edit.

You will see the id number of the category in the URL at the top of the page. If you then hover over the EN link within the editor, you will see the id number of this translated category at the bottom of your screen (see image)

You can use the following page as an example to test on:
hidden link

Afterwards, can you try to replicate the issue again on you normal shop page?

April 17, 2018 at 11:29 pm #1668204

Albin

I'm not sure if I understand correctly.
I went to categories, it looks like always. I also looked in the eng divi shop module, categories look same. No numbers. And shop not showing.

The topic ‘[Closed] Shop don't fully translate’ is closed to new replies.