This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Radu 10 months ago.

Assigned support staff: Radu.

Author Posts
August 6, 2019 at 12:11 pm


I am trying to: Show to shop main page in our primary language (danish). However the english translation works fine

Link to a page where the issue can be seen: hidden link however hidden link works fine

I expected to see: The shop page in danish

Instead, I got: Error 500 Internal Server Error

August 6, 2019 at 1:59 pm #4348113


Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Kristian,

Thank you for reaching out the WPML support!

I looked at the settings from your website but I couldn't find anything to look wrong. One thing was strange though: I went to Dashboard → WooCommerce → Settings → Products tab → Inventory → Shop page, and removed the Shop page from here, leaving the field empty. Once I saved the changes and checked once again the Shop page, it still wasn't loading. When this page is not selected in WooCommerce settings, it should display just a blank page (like you would create an empty page).

This makes me thing that there's something wrong with that URL (something that's not related to WPML). In this case, can you deactivate all the plugins except for WPML (and its add-ons) or WooCommerce, activate a default theme (like Twenty Nineteen), and tell me if the issue is still there, please?

Also, you can try to reach out the hosting provider too and ask him to have a look at this. Since the error message says Internal Server Error, the should be able to give you a few more details about what's making this to go wrong. You can share these details with me and see if there's anything I can help you with.


The topic ‘[Closed] Shop page doesn't work in primary language’ is closed to new replies.