This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
April 21, 2019 at 1:45 pm

amrS-3

I am trying to get WPML translation working correctly in the Shop page however it's randomly becomes blank in one of the languages (I have Arabic and English). I noticed that when it's not working for AR it will be working for EN and vice versa.

Link to a page where the issue can be seen:
hidden link
hidden link

Check attached

April 21, 2019 at 1:47 pm #3652595

amrS-3

Forgot to mention that the below steps didn't resolve my issue:

Please be sure to make a full backup of your site and database. Then, go to WPML -> Support -> Troubleshooting. Look for 'Clean up' and click the following:
- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

April 22, 2019 at 3:48 pm #3656883

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Could you tell me if the issue persists after increasing the memory limit?

Kind regards,
Carlos

April 22, 2019 at 4:04 pm #3656915

amrS-3

Thanks Carlos for your reply.

Memory limit increased, however this didn't resolve the issue. You can log in to the website and see what's going wrong. appreciate your quickest feedback, thx.

April 22, 2019 at 6:46 pm #3657921

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank yo very much for your message.

I took a deeper look at this issue and the Redux Framework plugin seems to be the culprit. However, the error comes from Woocommerce and you can see it in the sidebar of the shop page: Notice: Trying to get property of non-object in /home1/regalinh/public_html/wp-content/plugins/woocommerce/includes/class-wc-query.php on line 717

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Nineteen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

April 22, 2019 at 7:15 pm #3658035

amrS-3

This didn't resolve my issue as well. The reason behind the error coming from woocommerce is that the query doesn't return any records somehow. there must be a problem with the translated page.
P.S. I'm using WoodMart one of your tested compatible themes

April 22, 2019 at 8:04 pm #3658089

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Could you tell me if the issue persist while WPML is disabled?

Regards,
Carlos

April 22, 2019 at 8:14 pm #3658103

amrS-3

If WPML is disabled, how can I reproduce the issue?! the issue happens only when I switch from Arabic to English or vice versa

April 22, 2019 at 8:16 pm #3658107

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

If you disable WPML and the errors are still appearing the in the side bar of the shop page, then it's not related to WPML. If the errors persists then we will take a deeper look at this.

Regards,
Carlos

April 22, 2019 at 8:29 pm #3658235

amrS-3

Disabled WPML and accessed the page through URL and there i no errors appearing in the side bar.
P.S. I though giving you the full access to my website would make it easier for you doing direct tests for all what you might think it could be the reason.

Awaiting for a working solution 🙁

Thanks in advance

April 23, 2019 at 1:36 pm #3664373

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I asked you to do this test because I didn't had your confirmation that you made a full backup of the site. I'm sorry for the misunderstanding.

I would like to ask your authorization to make the necessary tests in the site and also, I kindly ask you to confirm that you made a full backup of the site, in case we need to restore it.

My next step will be to take a deeper look at the issue and try to reproduce the issue in a fresh new install if necessary.

Looking forward to your message.
Regards,
Carlos

April 23, 2019 at 2:50 pm #3665019

amrS-3

Hi Carlos,

Well, it looks like it's a known issue with WPML & Woocommerce I've fount a lot of tickets opened regarding this specific point with no real solution. Let me discuss with the client first if we can go with another alternatives to workaround this.

Thanks

April 23, 2019 at 5:26 pm #3666463

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Thank you very much for keeping me updated.

Note: We released a new copy of WPML + WCML plugins that fix several bugs, I recommend you to update the plugins to this new version and double check if the issue persists.

Regards,
Carlos